Bug 383681 - Incorrect identifier for ppc64 in org.eclipse.core.runtime.Platform
Incorrect identifier for ppc64 in org.eclipse.core.runtime.Platform
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: eclipse (Show other bugs)
5.1
ppc64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Andrew Overholt
desktop-bugs@redhat.com
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 20:43 EST by Norm Murray
Modified: 2011-01-24 17:16 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0441
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:34:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Customer tested patch (1.31 KB, patch)
2007-12-05 18:07 EST, Wade Mealing
no flags Details | Diff

  None (edit)
Description Wade Mealing 2007-11-14 20:43:16 EST
Description of problem:

in 
/usr/share/eclipse/plugins/org.eclipse.rcp.source_3.2.1.r321_v20060801-clWbqCmjexIWDqg/src/org.eclipse.core.runtime_3.2.0.v20060603/src.zip
 from the ppc64 rpms.  the zip file contains Platform.java which contains this
puzzling string.

public static final String ARCH_IA64 = "ppc64"; //$NON-NLS-1 $

I'm not sure why the ARCH_IA64 identifier would be used for ppc64 and why this
line is not contained within the 32 bit eclipse-rcp-sdk, with java being cross
platform and all.

Version-Release number of selected component (if applicable):

eclipse-rcp-sdk-3.2.1-18.el5.ppc64.rpm


How reproducible:

Every time 
Steps to Reproduce:
1. cd
usr/share/eclipse/plugins/org.eclipse.rcp.source_3.2.1.r321_v20060801-clWbqCmjexIWDqg/src/org.eclipse.core.runtime_3.2.0.v20060603/
2. unzip src.zip
3. grep "ARCH_IA64 " org/eclipse/core/runtime/Platform.java
  
Actual results:

        public static final String ARCH_IA64 = "ppc64"; //$NON-NLS-1$

Expected results:

        public static final String ARCH_PPC64 = "ppc64"; //$NON-NLS-1$

Additional info:

The method org.eclipse.core.runtime.Platform.getOSArch()
returns "ppc64", does return the correct architecture, however the constant
associated with it on org.eclipse.core.runtime.Platform. "ppc64" is associated
with ARCH_IA64, 

This can lead to problems as if we trust ARCH_IA64 to enable features on ia64
architectures these features will be also enabled on PPC64 (what is probably
wrong) and also cause some confusion as we will have to check for ARCH_IA64
architectures when running on PPC64 platforms.

I was unable to see this in the 32 bit version of RHEL5.
Comment 2 Ben Konrath 2007-11-14 22:00:05 EST
The ppc64 support in eclipse is hacked in because it's not supported by default
from eclipse.org. This is a bug in either the patch or the shell snippet that
adds support for ppc64. Moving bug to Red Hat Eclipse team.
Comment 6 John Jarvis 2007-11-30 11:34:27 EST
This is the business justification which did not make it over from Issue Tracker:

----- Additional Comments From lagarcia@br.ibm.com (prefers email at
lagarcia@linux.vnet.ibm.com)  2007-11-16 14:03 EDT -------
RHEL is the only supported platform for Cell SDK & IDE on PPC64. Without this
fix, Cell IDE is not functional and hence no RHEL user/SDK user will be able to
develop applications using the Eclipse GUI for Cell.
Comment 8 RHEL Product and Program Management 2007-12-01 08:12:52 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 14 Wade Mealing 2007-12-05 18:07:17 EST
Created attachment 278891 [details]
Customer tested patch

Customer says that this patch fixes said bug, although I'd like to think that
such an obvious issue would be the work of generated code, not a human making
that assumption.
Comment 31 errata-xmlrpc 2008-05-21 13:34:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0441.html

Note You need to log in before you can comment on or make changes to this bug.