Bug 383691 - Launched packagekit tools on pk applet are always below other windows.
Launched packagekit tools on pk applet are always below other windows.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 20:47 EST by sangu
Modified: 2008-10-04 10:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-04 10:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2007-11-14 20:47:26 EST
Description of problem:
Launched packagekit tools in panel tray are always below other windows.

Version-Release number of selected component (if applicable):
0.1.3-1.fc9

How reproducible:
always

Steps to Reproduce:
1. Launch "show updates" on PackageKit Update Applet
2.
3.
  
Actual results:


Expected results:


Additional info:
libwnck-2.21.2.1-1.fc9
Comment 1 Richard Hughes 2008-03-03 15:55:29 EST
I can't reproduce. What kind of windows are on top and what tool are you trying
to launch?
Comment 2 sangu 2008-03-03 18:44:08 EST
(In reply to comment #1)
> What kind of windows are on top and what tool are you trying to launch?
1. Launching in tray applet (notification area applet),
2 .See active window title bar on launched g-pk programs.
- Click pk-prefs(launched on notifciation area) - no change titlebar
- alt + tab(switch applications) -> See switcher. 
- Click pk-prefs in window list.
Please see < http://img90.imageshack.us/img90/571/switcherpe6.jpg >
Comment 3 Richard Hughes 2008-03-04 08:06:02 EST
I can't reproduce - i see the application in the metacity alt-tab switcher. If
you use metacity does that fix things for you?
Comment 4 sangu 2008-03-13 11:32:03 EDT
(In reply to comment #3)
> I can't reproduce - i see the application in the metacity alt-tab switcher. If
> you use metacity does that fix things for you?

You're right! This problem happens only in compiz.

----
compiz-0.6.2-6.fc9.i386
Comment 5 Bug Zapper 2008-05-13 23:54:10 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.