This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 38372 - Oracle 8.1.7.0.1 installation crashes when executing ./runInstaller
Oracle 8.1.7.0.1 installation crashes when executing ./runInstaller
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Mason
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 04:50 EDT by Thomas Kuczek
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 04:57:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Kuczek 2001-04-30 04:50:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


If you try to install Oracle and start ./runInstaller the program never
appears and your load goes up dramatically.

Reproducible: Always
Steps to Reproduce:
1. execute ./runInstaller from Oracle 8.1.7.0.1 
2.
3.
	

Actual Results:  the load of your machine goes up.

Expected Results:  the program should appear and you should be able to
install Oracle
Comment 1 David Mason 2001-04-30 10:52:22 EDT
I am not sure what this has to do with gnome-core but I will leave it in my
hands until you reply to this question.... did you read the release notes during
your upgrade process, or on your CD or ISO? We address problems with Oracle and
7.1 there:

    o The Oracle installation program (versions 8.1.7, 8.1.6, and possibly
      others) does not work properly with glibc 2.2 and above.  The problem
      is that it is linking object files compiled against different glibc
      (binary compatibility is ensured only for linked executables and
      shared libraries through symbol versioning).  You may work around
      this by installing the Red Hat Linux 6.2 compatibility packages
      (compat-egcs, compat-glibc and compat-libs) and issuing the following
      commands before running the Oracle installer:

        export LD_ASSUME_KERNEL=2.2.5
        . /usr/i386-glibc21-linux/bin/i386-glibc21-linux-env.sh

      The second line exports environment variables which will cause gcc
      and ld to look for glibc 2.1.3 compatibility headers and libraries


I do not think we have had much help from Oracle in terms of updates to their
packages, but you can check with them. Please respond that this either worked or
didnt and I will try to either assign it to the correct person or close the bug
and get you some help outside of this system.
Comment 2 Thomas Kuczek 2001-04-30 11:11:22 EDT
I didn't know where to put this bug. I had no idea why the Oracle Installer 
didn't appear. Sorry.

Actually this explains my problem, I think you can close the bug. Thanks for 
the quick response.

Greetings Thomas
Comment 3 David Mason 2001-04-30 11:48:28 EDT
no problem :)
Comment 4 Thomas Kuczek 2001-05-15 12:42:43 EDT
Actually, what do you mean with
compat-libs
I can't find any RPM that sounds like this.

Greetings Thomas
Comment 5 David Mason 2001-05-15 16:05:31 EDT
Disc one - RedHat/RPMS/compat-glibc-6.2-2.1.3.2.i386.rpm
Comment 6 Thomas Kuczek 2001-05-16 10:29:18 EDT
Which rpm provides the script:
. /usr/i386-glibc21-linux/bin/i386-glibc21-linux-env.sh
?

It's not in my installation.

extra RPM's installed:
compat-glibc-6.2-2.1.3.2
compat-egcs-6.2-1.1.2.9
kgcc-1.1.2-40

Thomas
Comment 7 Thomas Kuczek 2001-05-21 08:52:40 EDT
I found a duplicate bug!
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=38455

I think it is the same one then this one...

Could you give me an answer to my last question?
Which rpm provides the script:
 . /usr/i386-glibc21-linux/bin/i386-glibc21-linux-env.sh
 
Greetings Thomas
Comment 8 David Mason 2001-05-21 10:07:45 EDT
I'm sorry I just dont see that file on any system - thus I cannot verify what
provided it - are you being queried for this file? Thanks for pointing out the
duplicate
Comment 9 Thomas Kuczek 2001-05-21 10:19:10 EDT
You told me in your comment:
Additional comments from dcm@redhat.com 2001-04-30 10:52:22 
to run this file.

export LD_ASSUME_KERNEL=2.2.5
. /usr/i386-glibc21-linux/bin/i386-glibc21-linux-env.sh

Now I am searching for this file...

Greetings Thomas
Comment 10 David Mason 2001-05-21 10:24:39 EDT
oh - sorry ... in the release notes... right :) I should actually read them :)
Let me dig deeper...
Comment 11 David Mason 2001-05-21 10:46:07 EDT
OK I have screwed you up enough... the compat libraries are also on disc 2 you
will need the compat-egcs* and compat-libs*.

compat-egcs-6.2-1.1.2.14.i386.rpm contains the file you need

Give that a shot
Comment 12 Daniel Hammer 2001-05-21 17:03:57 EDT
But anyway, I've read the comments from the release notes 'n did of course try

export LD_ASSUME_KERNEL=2.2.5
         . /usr/i386-glibc21-linux/bin/i386-glibc21-linux-env.sh

but it does not help in any way under any window manager. I wonder if there is
any success story of installing Oracle under RH 7.1 ... and if yes under what
setting. I've tried nearly everything on several machines, but unfortunately I
didn't even got a glimpse.
I don't like to discuss how good/bad oracle Products are - I _just need to
install_ them & what I see is: 
o under RH-6.2 everything is fine; 
o under RH-7.0 one can install at least the client software but no data base
o under RH-7.1 even the java installer stuff from OUI does not show up

Any suggestions? Any help is much appreciated!
Comment 13 David Mason 2001-05-21 17:22:39 EDT
can you give me more on what window manager problem you are having? did it
install at all?
Comment 14 Thomas Kuczek 2001-05-21 17:36:55 EDT
Mini success...
I have tried it with

export LD_ASSUME_KERNEL=2.2.5
. /usr/i386-glibc21-linux/bin/i386-glibc21-linux-env.sh

these commands and guess what? The Installer appeared (under gnome) and I was 
able to install Oracle! After that installation I tried to built the database, 
but you know, this takes a long time, so I went home.
I am going to tell you tomorrow, if it was also successful or not.

Greetings Thomas
Comment 15 Daniel Hammer 2001-05-21 18:02:12 EDT
I tried on a fresh install (with all available compat-* packages)

export LD_ASSUME_KERNEL=2.2.5
   (and 'env|grep LD tells me that the environment variable is set)
. /usr/i386-glibc21-linux/bin/i386-glibc21-linux-env.sh

under GNOME with sawfish, enlightenment and with WindowMaker and even under KDE.
What I see is 

"Initializing Java Virtual Machine from
 ../stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/jre.
 Please wait..."
Doing 'ps aux' I see 2 relevant processes running 

/mnt/cdrom/install/linux/runInstaller
/mnt/cdrom/stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/linux/native_th

but nothing happens, even if waiting for a long time.
Comment 16 David Mason 2001-05-21 18:10:39 EDT
I am not sure why this is a window manager issue?? I am not sure what is going
on here.
Comment 17 Daniel Hammer 2001-05-21 18:31:59 EDT
> I am not sure why this is a window manager issue??
I never said so & looks like you're right - it is not

>  I am not sure what is going on here.
;-)  if I could ever know ;-)
what scares me is that the same weired story I have on every machine (really
different ones SCSI/IDE/Graphics/etc)
Comment 18 Thomas Kuczek 2001-05-22 04:57:19 EDT
Jupee,
it worked. Oracle 8.1.7.0.1 is up and running! I am uber happy.

Thanks for your help
Greetings Thomas
Comment 19 David Mason 2001-05-22 10:36:39 EDT
dhammer@noos.fr
: perhaps you can strace this process and file as a new bug under the
'distribution' module - that way we can look at your problem in particular and
close this bug that was solved for Thomas
Comment 20 Thomas Kuczek 2001-05-23 04:30:49 EDT
Hi all,
this is a complete installation instruction with links to all the stuff, that 
you need to install Oracle 8.1.7.0.1 on RedHat 7.1

http://www.thomasfly.com/Oranux/

Greetings Thomas

Note You need to log in before you can comment on or make changes to this bug.