This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 383721 - gnomesword non-functional in f8: error while loading shared libraries: libgtkembedmoz.so
gnomesword non-functional in f8: error while loading shared libraries: libgt...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnomesword (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
brokendep
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 21:29 EST by David Campbell
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 12:27:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Campbell 2007-11-14 21:29:14 EST
Description of problem:


Version-Release number of selected component (if applicable):

2.3.1

How reproducible:

Always

Steps to Reproduce:
1. Install gnomesword
2. Run gnomesword
 
Actual results:

[dcampbel@host15-101 images]$ gnomesword2
gnomesword2: error while loading shared libraries: libgtkembedmoz.so: cannot
open shared object file: No such file or directory


Expected results:

Should run

Additional info:

This libgtkembedmoz.so is present in the firefox installation, in export
/usr/lib/firefox-2.0.0.8

A temporary workaround to this problem is to do the following from the commandline:

export LD_LIBRARY_PATH=/usr/lib/firefox-2.0.0.8
gnomesword2
Comment 1 David Campbell 2007-11-14 21:54:51 EST
No, that temporary workaround doesn't work.  It gets some way but the
application doesn't properly start.
Comment 2 Deji Akingunola 2007-11-14 22:15:00 EST
I'm very sorry about this bug. The problem was that the package was built with
firefox-2.0.0.9, but that version of firefox hasn't made it to updates yet. I'll
investigate how to best fix this.
Comment 3 Will Woods 2007-11-15 12:27:07 EST
firefox-2.0.0.9 is now available in the updates repo; gnomesword works for me.

Note You need to log in before you can comment on or make changes to this bug.