Bug 383841 - "mute" button does not work on Thinkpad X61
"mute" button does not work on Thinkpad X61
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 22:41 EST by petrosyan
Modified: 2013-01-09 23:30 EST (History)
4 users (show)

See Also:
Fixed In Version: kernel-2.6.25-0.155.rc6.git8.fc9.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 16:01:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 9907 None None None Never

  None (edit)
Description petrosyan 2007-11-14 22:41:38 EST
Description of problem:
Sound "mute" button does not work on Thinkpad X61. Smolt harware profile is
http://smolt.fedoraproject.org/show?UUID=810e7126-1c69-4aff-b8b1-9db0fa8aa15a
Comment 1 Bill Nottingham 2007-11-15 13:16:50 EST
This is the hardware button, correct?
Comment 2 petrosyan 2007-11-15 16:03:08 EST
Correct. Software muting works.
Comment 3 Bill Nottingham 2007-11-15 16:07:28 EST
Is thinkpad_acpi loaded?
Comment 4 petrosyan 2007-11-15 16:59:56 EST
Yes, it is loaded.
Comment 5 petrosyan 2007-11-15 22:41:44 EST
Pressing "mute" button actually mutes the sound, but the software mixer does not
notice it. Software mixer does notice volume_up, and volume_down button presses.
Comment 6 Bill Nottingham 2007-11-16 09:46:16 EST
OK, for the hardware mute to show up in the mixer would require ALSA work.
Comment 7 Chuck Ebbert 2008-01-16 18:03:50 EST
Does adding this kernel boot option help:

  acpi_osi="Linux"
Comment 8 petrosyan 2008-01-16 19:17:59 EST
Adding acpi_osi="Linux" to kernel-2.6.23.9-85.fc8 on a standard Fedora 8 install
fixed this bug.

Is it possible in integrate the fix into the next Fedora kernel update?
Comment 9 Kevin R. Page 2008-01-17 07:35:26 EST
To be clear: should acpi_osi="Linux" fix the hardware mute showing up in the
mixer (and OSD appearing etc.)?

With 2.6.23.9-85.fc8 (on Thinkpad X61s), both with and without acpi_os="Linux",
the hardware mute works, but doesn't show up in the mixer (as per comment #5). 

Keyboard in /etc/X11/xorg.conf is "gb+inet" ("gb+inet(thinkpad)", which some
sources suggest I might want, stops the volume buttons working).
Comment 10 petrosyan 2008-01-17 10:44:00 EST
my keyboard is "us+inet"
harware mute works both with and without acpi_osi="Linux"
adding acpi_osi="Linux" makes mixer respond to the "mute" button.
also before adding acpi_osi="Linux" xev wasn't detecting anything when pressing
the mute key, after adding it xev detects the key press.
Comment 11 Kevin R. Page 2008-01-17 11:46:48 EST
Changing to us+inet does nothing for me (apart from mess up my keymap ;)  )
Nothing from xev.

Which BIOS version are you using? I'm on 1.08 (7NET27WW). It looks like X61 and
X61s use the same BIOS. If you're running a newer version I'll try updating.
Comment 12 petrosyan 2008-01-17 14:01:18 EST
I am using BIOS v1.10
Comment 13 Kevin R. Page 2008-01-21 09:27:43 EST
Confirmed: with BIOS 1.11 and acpi_osi="Linux" mute button keypresses are passed
through to the software mixer as described in comment #10.
Comment 14 petrosyan 2008-01-21 14:16:24 EST
Kevin, where did you get BIOS 1.11? On Lenovo's website the latest BIOS is 1.10
Comment 15 Kevin R. Page 2008-01-21 14:49:25 EST
From the Lenovo website I select my location (UK), enter the Thinkpad type
number, go to downloads then BIOS - bootable CD - and I get:
File details
Version: 	7NET30WW (1.11)
Release Date: 	2007/11/26

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-67983
Comment 16 Christopher Brown 2008-02-13 17:15:12 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

It appears as though the BIOS update may resolve the issue - is that correct?

If the problem no longer exists then please close this bug or I'll do so in a
few weeks if there is no additional information lodged.
Comment 17 petrosyan 2008-02-13 19:39:38 EST
I am currently using the latest BIOS update:
Version: 	2.06
Release Date: 	2007/12/28

and the latest Fedora 8 kernel-2.6.23.15-137.fc8
and the bug is still present.
Adding acpi_osi="Linux" kernel boot option fixes the problem.
Comment 18 petrosyan 2008-02-14 20:21:00 EST
I just tried kernel-2.6.25-0.35.rc1.fc9 and this bug was still present.
kernel-2.6.25-0.40.rc1.git2.fc9 did not boot on ThinkPad X61.
Comment 19 petrosyan 2008-03-26 16:01:57 EDT
this bug has been fixed in kernel-2.6.25-0.155.rc6.git8.fc9.x86_64

Note You need to log in before you can comment on or make changes to this bug.