Bug 38389 - Edit Personal Info changes Corporate AC to Personal AC
Edit Personal Info changes Corporate AC to Personal AC
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 09:01 EDT by Richard Crandall
Modified: 2009-03-24 14:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 14:06:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Crandall 2001-04-30 09:01:23 EDT
A corporate account was set up on the web store to place an order for Red
Hat network.  The customer was imported into Oracle Receivables as a
corporate customer (customer name = Company, user = contact).  After the
order was placed, the personal information was edited (the email address
was changed) and the customer data in Oracle Receivables was changed to a
personal web account with customer name = contact name.
Comment 1 Jeffrey Cohen 2001-04-30 12:26:27 EDT
I think that the problem stems from the 'rhn_register' program.

When initially starting 'rhn_register',   a customer is able to enter company
info and such.  If an account already exists in Oracle as a 'web-user-business'
type, this causes problems.  

For example.  

Oracle Customer 312721.  I originally set this customer up over the web site as
a new corporate account. 'Rio Brazos Education Cooperative' with the  Contact
'BC Anness.' Everything imported into Oracle fine.  

Now, a few days later I looked at the customer's record and saw that the
customer had been changed to 'BC Anness' and type 'web_user_personal' 
Interestingly, in the flex-field on the Customer Record Form in Oracle where
company name is placed was found 'Rio Brasos Education CO-OP'.  This company
name is quite different than the one I had entered and had to come from
somewhere.  Since all the forms available on the web site do not allow company
names to be entered once the customer is created, I figured the company name was
entered through 'rhn_register'.  

'rhn_register' then updates the customer record in Oracle with the new
information.  Since 'rhn_register' considers all records to be of type personal,
the record is thusly changed in Oracle.

Perhaps something needs to be changed.

Thanks.

-Jeff
Comment 2 Jay Turner 2001-05-15 14:23:25 EDT
Pushing this over to the rhn_register component to make sure that it ends up on
the issues list.
Comment 3 Cristian Gafton 2001-08-10 16:57:54 EDT
Assigned to the owner of component
Comment 4 Greg DeKoenigsberg 2002-02-28 18:49:33 EST
Just as an additional note: we need to move away from creating accounts from
rhn_register except for accounts that we know to be personal.

Corporate accounts should not be created through rhn_register.  Messaging in the
creation flow should indicate that for Business accounts, the account should be
created at https://rhn.redhat.com.
Comment 5 Todd Warner 2002-09-17 15:35:37 EDT
7 months old.... any resolution?

Note You need to log in before you can comment on or make changes to this bug.