Bug 38391 - boot from CD ok; then could not find a Red Hat Linux CDROM error thrown
boot from CD ok; then could not find a Red Hat Linux CDROM error thrown
Status: CLOSED DUPLICATE of bug 22285
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 09:30 EDT by B.M.
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 17:12:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description B.M. 2001-04-30 09:30:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)


I can boot from RedHat CD without any problems. Kernel from CD is loaded, 
installer starts. I can choose language and keyboard. Then I should 
choose, if I want to install from CD or hard drive. Choosing CD, I get 
this error: "Could not find a Red Hat CDROM in any of your CDROM drives. 
Please insert the Red Hat CD and press OK".

Same error is reported from more users in: "Support Forums>Red Hat Linux 
Installation and Configuration Support Forum>Installation Assistance" 
(http://www.redhat.com/WebX?13@40.Wg8qaHCaveD^4@.ee70435/0)

Using "linux hdX=cdrom" has no influence on this problem.

Note: I can mount and read this CD in already installed linux without any 
problems. (i.e. CD seems to be ok)

Reproducible: Always
Steps to Reproduce:
1. Boot from linux CD (disk1)
2. Choose language and keyboard.
3. Choose installation from CDROM.
4. In this moment error appears. 
	

Actual Results:  Error "Could not find a Red Hat CDROM in any of your 
CDROM drives. Please insert the Red Hat CD and press OK" appears.

Expected Results:  CDROM should be found :)

On text console Alt-F3 is written:
* trying to mount device hdc 
* loopfd is 7
* failed to mount loop: No such device

On text console Alt-F4 is written:
<7> ISO 9660 Extension: RRIP_1991A
<4> Unable to identify CD-ROM format.
<4> VFS: Can't find an ext2 filesystem on dev loop(7,0).
Comment 1 Brent Fox 2001-04-30 11:42:47 EDT
Try making a boot disk with the boot.img file in the /images directory on the
cdrom.  Boot off this floppy and then select CDROM as the installation type.
Does this fix the problem?
Comment 2 B.M. 2001-05-04 08:11:53 EDT
I can create boot disk without problems, i.e. no error from rawrite (I do not 
know, if rawrite checks something).
But I can not boot from it. Computer freezes immediately after it starts to 
boot from drive (no LILO prompt, no output, just freezes).
Diskette is ok, booting from a: drive is ok in all other cases.
I only can not boot boot.img.

I have two ideas:
1. conflict with hardware, but I have not any other problems using other OSs 
including older RedHat. (btw, KT7 without RAID, Duron 750)
2. corrupted CD, but can read whole CD without problems
Comment 3 Brent Fox 2001-05-04 11:11:10 EDT
Try booting with 'linux ide=nodma'.  Does this help?
Comment 4 B.M. 2001-05-14 04:37:05 EDT
CD (iso image used by vendor) was corrupted
I was confused by possibility to boot and read whole CD... sorry
problem is solved and can be closed (rejected)
Comment 5 Brent Fox 2001-05-14 16:38:56 EDT
It's ok...we get a lot of bug reports that turn out to be bad ISO images. 
Thanks for your report.
Comment 6 Need Real Name 2001-05-17 21:18:55 EDT
I don't think this should be closed. I can reproduce the same thing on my 
machine with my regulation copy of Redhat professional server, with CDs burned 
from isos, and with a copy of my "real" CD. My machine is a Supermicro 370DE6 
with an IDE drive and cdrom. I have no problems installing on my other machine 
that has a SCSI cdrom. I have also found that if I start in text expert mode 
and then say yes when prompted for a driver disk with no floppy in the drive a 
couple of times it will then find the cdrom drive. It also seems to like it if 
I wait till the drive spins down before I start the install.
Comment 7 Brent Fox 2001-05-21 11:14:07 EDT
khill2, did you boot with 'linux ide=nodma'?  Also, do you see any error
messages on VC3 or VC4?
Comment 8 Pekka Savola 2001-05-23 16:34:13 EDT
I do not think this should be closed just yet.

I got into a similar situation when rebuilding RHL71 CD.  Previously I have done the same for RHL62 and RHL7
without problems.  However, now I got the same messages as above:

When booting from the CD, you get kernel messages:

<7> ISO 9660 Extension: RRIP_1991A
<4> Unable to identify CD-ROM format.

and the installer fails with a message:

Could not find a Red Hat CDROM in any of your
CDROM drives. Please insert the Red Hat CD and press OK

I've tested this extensively (wasted about 6 cd's) on two P2's with IDE
CD-ROM (one of which has had no problems reading RHL62 and RHL7 custom
CD's), and I can say:

- ide=nodma has no effect
- setting dma, etc. options in bios has no effect
- whether 650 or 700 MB CD is being used has no effect
- whether burned at 4x or 8x (reliable scsi cd-r) has no effect
- whether Joliet is being used in CD-generation has no effect
(generating with:
mkisofs -r -c boot.cat -b images/boot.img -V "RHL" -o ../rh.iso . )
- whether booted from floppy or cd has no effect
- mkisofs 1.8 vs 1.9 has no effect

All the CD's tested read fine when RHL is loaded.  I've taken md5sum of
the iso before and after transfer, should be fine.

I've installed using FTP from the same tree I built from, no problems.

I'm wondering if I've stumbled on a kernel issue.


Note: when reading the CD in kernel-2.4.3-5, after mounting I get:

hdd: ATAPI 7X CD-ROM drive, 120kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12
ISO 9660 Extensions: RRIP_1991A

At boot, I only got:

hdd: 685A, ATAPI CD/DVD-ROM drive

I wonder if this is significant (ie. the Uniform CD-ROM driver loading).

Any ideas what to try next?
Comment 9 Pekka Savola 2001-05-25 03:44:25 EDT
My problem appears to have been slightly different, as I didn't get:
<4> VFS: Can't find an ext2 filesystem on dev loop(7,0).

I had edited syslinux.cfg on boot.img floppy to automatically use:

ks=cdrom:/extra/ks.cfg

This worked fine (up to this point anyway) on RHL7.  Here, it makes the
installer fail.

using ks=floppy, for example, makes all those dud CD's work without a glitch.

Apparently:

 1) the "Unable to identify CD-ROM format" is non-critical (Why does it
occur though?)
 2) kickstart from the CD fails the installer, creating the "Could not
find a Red Hat CDROM in any of your CDROM drives. Please insert the
Red Hat CD and press OK" -screen.
Comment 10 Brent Fox 2001-05-29 17:11:55 EDT
1) The "Unable to identify CD-ROM format" is non-critical.  This is coming from
the kernel.  If you look in /usr/src/linux-2.4/fs/isofs/inode.c:


        /*
         * If we fall through, either no volume descriptor was found,
         * or else we passed a primary descriptor looking for others.
         */
        if (!pri)
                goto out_unknown_format;


and then later:

out_unknown_format:
        if (!silent)
                printk(KERN_WARNING "Unable to identify CD-ROM format.\n");

I still don't know exactly why it occurs, but it can be safely ignored.

2. Kickstart installs don't work if the kickstart file is on the cdrom.  This is
a known issue and we are fixing it.  This is a dupe of 22285

*** This bug has been marked as a duplicate of 22285 ***

Note You need to log in before you can comment on or make changes to this bug.