Bug 38397 - Anaconda crashes with signal 11 immediately after starting.
Anaconda crashes with signal 11 immediately after starting.
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-30 11:37 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-02 03:00:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-30 11:37:53 EDT
Attempting to upgrade from RH7.0 to RH7.1 with the boxed Deluxe Workstation
(product id = 6357-d370-f912-0e98), and the install fails almost
immediately after aconda starts. System is non-descript AMD K6-2/450MHz
with 512 Meg Ram, 30 Gig Maxtor as boot drive.  The sequence of events are:

1.  AMI BIOS, with AMD K6-2/450MHz, memory test, etc.
2. Red Hat Welcome Screen
3.   boot:
4.  one to two pages of text while system initializes from cdrom
5. a blue screen
6. a message (as blue screen scrolls up):
	" Running Anaconda - please wait"
7. immediately followed by another message:
	" install exited abnormally - - recieved signal 11
	sending termination signals ... done
	sending kill signals ... done
	disabling swap
	unmounting filesystems
		/mnt/source umount failed ()
	you may safely reboot your system "

And that is it.  I tried every installer option which makes
sense for this system, and the results are consistent and
repeatable across options.

Fortunately, the install has not gotten to the place where
the existing 7.0 install gets corrupted.

BTW, this system has had several generations of RH
versions installed on it, and this is the first version which
would not install.  It is not a defective cd, as I used the
same store-bought cds to install on another machine
which has few similarities beyond being Intel iron.
Comment 1 Brent Fox 2001-04-30 11:44:18 EDT
Arjan, does this sound like a kernel problem?
Comment 2 Arjan van de Ven 2001-04-30 11:46:00 EDT
Could you try starting the install with "ide=nodma" ?
If it works, your CDrom drive doesn't like IDE DMA transfers and we need
to add it to the blacklist for DMA.
Comment 3 Need Real Name 2001-05-02 03:00:47 EDT
Dear arjanv and bfox:  I did as you requested and entered:  linux ide=nodma at
the boot prompt. That allowed the cdrom boot process to sail through correctly. 
I assume your prognosis was correct. In case you need to put my CDROM drive on
the black list, it is: Toshiba CD-ROM XM-6202B, ATAPI.  I should also mention
that I have two other odd items on this machine which could possibly have
affected anaconda in some way: a Mouse Systems white (serial) mouse, which the
installer couldn't find.  That could be because it identified a PS/2 mouse, and
that could be because I did not disable the on-board PS-2 mouse support in the
BIOS;  the other item which is odd is the pseudo tulip (PNIC) Ethernet chip,
which used to require a special version of the tulip driver, but Seawolf threw
out the old configuration and put in a new one which is obviously working fine,
as I am using it now.  It is probably the cd-rom drive.  

Thank you very much for your prompt assistance.  Red Hat Rules!

Gene Montgomery.
Comment 4 Arjan van de Ven 2001-05-02 05:05:05 EDT
The PS/2 issue is complex.. and disabling in the bios is the best way to
deal with this.

I'll close this bug as "RAWHIDE" as it now works for you and I've added
your drive to the list of "devices not to do DMA on". If you object to that,
please reopen this bug.
Comment 5 David Beach 2004-07-24 15:42:21 EDT
Had same problem and using ide=nodma worked. The CD in this case was 
Creative CD3230E, which you should add to your list of devices that 
can't handle DMA.

Note You need to log in before you can comment on or make changes to this bug.