Bug 38399 - pine 4.33 whitespace breakage
pine 4.33 whitespace breakage
Status: CLOSED DUPLICATE of bug 23679
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On: 23679
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 12:15 EDT by Matt Domsch
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-23 17:23:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch-before-pine.gz (348 bytes, application/octet-stream)
2001-04-30 12:24 EDT, Matt Domsch
no flags Details
patch-before-pine.hex (2.47 KB, text/plain)
2001-04-30 12:25 EDT, Matt Domsch
no flags Details
patch-after-pine.gz (346 bytes, application/octet-stream)
2001-04-30 12:25 EDT, Matt Domsch
no flags Details
patch-after-pine.hex (2.40 KB, text/plain)
2001-04-30 12:26 EDT, Matt Domsch
no flags Details
pine-breakage.diff (2.27 KB, text/plain)
2001-04-30 12:26 EDT, Matt Domsch
no flags Details
Same bug, same patch (updated). Please apply. (1.55 KB, patch)
2001-06-11 18:58 EDT, David Woodhouse
no flags Details | Diff

  None (edit)
Description Matt Domsch 2001-04-30 12:15:45 EDT
This is a bug report against Pine 4.33 as found in Red Hat Linux 7.1,
pine-4.33-8, running on an i386-based platform.

I've run into strange case where pine, when sending mail, mangles
whitespace, in this case, inside of a patch.  Attached are
several files.  patch-before-pine.gz contains the patch as extracted by
diff -bu (compressed for this message to ensure it says the same, but was
included in the message body as text when sent).  patch-after-pine.gz
contains the patch as exported from pine after being sent/received.

In looking at a diff of the hex dump, you'll see that
\n[space]\n[space*7]\n got merged into \n\n\n.  This causes the
patch, when received, to fail to apply.

-0000150   s   [   3   ]   )   )   ;  \n      \n
-0000160      \n   +                           s   c   s   i   _   s   e
+0000150   s   [   3   ]   )   )   ;  \n  \n  \n   +
+0000160       s   c   s   i   _   s   e   t   _   p   c   i   _   d   e
Comment 1 Matt Domsch 2001-04-30 12:24:40 EDT
Created attachment 16847 [details]
patch-before-pine.gz
Comment 2 Matt Domsch 2001-04-30 12:25:13 EDT
Created attachment 16848 [details]
patch-before-pine.hex
Comment 3 Matt Domsch 2001-04-30 12:25:46 EDT
Created attachment 16849 [details]
patch-after-pine.gz
Comment 4 Matt Domsch 2001-04-30 12:26:15 EDT
Created attachment 16850 [details]
patch-after-pine.hex
Comment 5 Matt Domsch 2001-04-30 12:26:52 EDT
Created attachment 16851 [details]
pine-breakage.diff
Comment 6 Mike A. Harris 2001-05-06 01:58:05 EDT
Hopefully will be fixed in PINE 4.34 or whatever is the next release.
Deferring for next official PINE release. (or patch submission)

Workaround: Send patches as file attachments.  (Yes, I know this p*ss*s
Linus off)  ;o)
Comment 7 Mike A. Harris 2001-05-19 02:59:29 EDT
Any word back from the pine team on this?  I wish they would open PINE CVS
up to the world so that hotfixes can be pulled from it...
Comment 8 Matt Domsch 2001-05-19 10:28:28 EDT
No comments at all from either pine list I sent the bug report to.
Comment 9 Mike A. Harris 2001-05-28 17:53:13 EDT
That's a typical response from closed development projects.  I just updated
our pine package with a pinepgp fix, but I don't suspect another update until
a new release of PINE is available.
Comment 10 David Woodhouse 2001-06-11 18:18:41 EDT
This looks like a duplicate (and indeed a regression) of Bug #23679, which was
fixed many moons ago in a 7.0 erratum release, IIRC. I haven't yet verified that
the cause is the same gratuitous stripwhitespace() call just before sending the
mail. I suspect it is.
Comment 11 David Woodhouse 2001-06-11 18:58:27 EDT
Created attachment 20782 [details]
Same bug, same patch (updated). Please apply.
Comment 12 Mike A. Harris 2001-06-23 16:45:45 EDT

*** This bug has been marked as a duplicate of 23679 ***

Note You need to log in before you can comment on or make changes to this bug.