Bug 38400 - Installation freezing on Toshiba laptop
Installation freezing on Toshiba laptop
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 12:17 EDT by lionel azikiwe
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-20 13:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lionel azikiwe 2001-04-30 12:17:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


I recently tried to upgrade my Toshiba Laptop 1605cds from Redhat 7.0 to 
7.1 seawolf edition but everytime i try to load it it ends up freezing out 
at somepoint without any error messages. I had no problem with installing 
7.0 and i still don't have any problems with installing 7.0 today. I have 
tried installing 7.1 (seawolf) in expert mode but the same thing also 
seems to happen sometimes it will get up all the way to where it is 
installing packages and then freeze and sometimes it will only get to the 
part where it is asking for the mouse type then freeze, other times it 
freezes if left alone for a little while. I am really in dire need of 
getting this working so i can complete my transition from windows to linux 
and possibly convince my company to do the same.

Reproducible: Always
Steps to Reproduce:
1.Put in the 7.1 seawolf cd-rom containg the iso image disk 1
2.boot up the machine press F3 and type expert 
3.Select all the needed items and keep going 

	

Actual Results:  it keeps freezing at odd times i don't know whether it 
has anything to do with cd-rom spining too much or the computer gets to 
hot or something but none of these things seem to happen in 7.0

Expected Results:  it should have loaded successfully without any errors, 
i am pretty confident in my abilities to load nad configure red hat 
operating systems since i have done quite a lot.

is this a none issue and what is the best way to combat it is there a 
patch for it, any help is highly needed.
Thanks
Comment 1 Brent Fox 2001-04-30 12:32:55 EDT
Did you burn the cd's or get them in the boxed set?  If you downloaded them, I
would check the md5sums of the ISOs to make sure that nothing got corrupted
during the download.

Do these cd's work in any other machines?
Comment 2 lionel azikiwe 2001-04-30 14:00:42 EDT
I burned the iso's from one of the mirror sites and i have been able to use 
them successfully on a desktop system but i need to deploy and test it on 
laptops. Just in case it has something to do with the Md5sums, how do i go 
about checking that out.

Thanks
Comment 3 Brent Fox 2001-04-30 17:38:07 EDT
If the isos are on a Linux box, run the 'md5sum' command...like 'md5sum
whatever.iso'.  It will take a long time, but you should see the checksum
information after it is through.  Also, there are some freeware Windows
utilities to do this on a Windows box, but I don't have the URL's for them handy.
Comment 4 lionel azikiwe 2001-04-30 18:14:15 EDT
Unfortuantely the iso's have been burnt to a disk already but i have a linux 
box that is running red hat 7.0. Can i mount the iso cd-rom to /mnt/cdrom/ and 
run the md5sum command like you specified above
Comment 5 Brent Fox 2001-05-01 10:46:51 EDT
No, you can't really check the md5sum on the cd itself, you have to do it on the
ISO image that you downloaded.  When the machine hangs, can you go to VC3
(<Ctrl><Alt><F3>) and VC4 (<Ctrl><Alt><F4>) and see if you see any error messages?
Comment 6 lionel azikiwe 2001-05-01 13:37:15 EDT
I will try reloading it again today and try to the key combinations to try to 
check the error messages and i will also try to  look for the iso images in the 
downloaded form .
Comment 7 lionel azikiwe 2001-05-01 14:27:30 EDT
Actually i found the iso , it is on a windows system,(seawolf-i386-disc1-
2.iso), how do i go about checking the md5sum on it ona windows system, i can't 
transfer it to my laptop since it might use up a whole lot of space
Comment 8 Brent Fox 2001-05-01 15:12:13 EDT
There are some freeware Windows utilities for checking md5sums.  I don't know
how well they work, but they should work ok.  Here's a URL for one of them
called md5summer:

http://download.cnet.com/downloads/0-10096-100-3728229.html?tag=st.dl.10001-103-1.lst-7-1.3728229
Comment 9 lionel azikiwe 2001-05-01 18:42:40 EDT
Ok i downloaded that program that you recommended and i used it to create a 
md5sum for the iso that i have seawolf-i386-disc1-2.iso and the MD5sum that i 
got is 596b1575773e88e066326f6741312a6f and then i went back to the mirror site 
that i downloaded it form download.sourceforge.net and retrieved the MD5sum 
that they had for seawolf-i386-disc1.iso and it was 
f27b912299572a542cd663b712444445. This is all i have for now, what do you 
think? did i do it correctly
Comment 10 lionel azikiwe 2001-05-02 09:32:44 EDT
I also tried to re-install it again but it froze and i tried the key 
combinations you mentioned V3(<Ctrl><Alt><F3>) and VC4 (<Ctrl><Alt><F4>) but i 
couldn't get or see anything.
Comment 11 Brent Fox 2001-05-02 13:09:29 EDT
In your last post, you said you used Md5Summer to check the md5sum of the
"seawolf-i386-disc1-2.iso"...do you mean disk 1 or disk 2?  I don't understand
the "disk1-2.iso" part...

Comment 12 lionel azikiwe 2001-05-02 15:41:51 EDT
Sorry about that i meant disk1 not disk2. The MD5sum was for disk1
Comment 13 Brent Fox 2001-05-02 15:59:04 EDT
Ok, your md5sums don't match.  They should be identical.  This means that
something got scrambled when the iso came over the network, which means that
there is no chance for the install to complete properly.  Try redownloading and
burn a new cd.  Please reopen this bug if  the problem persists after this.
Thanks for your report.
Comment 14 lionel azikiwe 2001-05-07 09:57:17 EDT
I FTPed into Ftp.redhat.com and downloading the Two iso's and burnt them to 
discs on friday and then tried to install them onto the laptop again and then 
the samething happened again (i.e freezing), i tried out the disc's on a 
desktop and then installation went fine and smooth with one single problem 
which led me to the conclusion that it had nothing to do with the disc's. My 
issue right now is how do i get red hat 7.1 onto the laptop, is it possible to 
do it via an online upgrade in which case the kernel will be upgraded to the 
latest version or should i re-compile the kernel to reflect new changes that 
will be beneficial to the laptop devices or is there any other way you think i 
should go about this whole issue.
Comment 15 Brent Fox 2001-05-07 16:16:44 EDT
Try booting with 'linux ide=nodma'.  Does that help?
Comment 16 lionel azikiwe 2001-05-09 09:46:49 EDT
I tried feeding the argument you specified above to kernel at boot time but 
that didn't help as it still kept freezing at some point.
Comment 17 Brent Fox 2001-05-09 10:54:02 EDT
Well, one way to get 7.1 on the system is to install 7.0 and then upgrade the
RPMs by hand.  Basically, put the 7.1 cd in the machine and go to the RPMs
directory and start doing 'rpm -U *.rpm' for the packages you want to upgrade. 
After you upgrade the kernel package, though, *BE SURE* to go change your
/etc/lilo.conf file to boot from the new kernel.  Otherwise your system will be
unbootable.


Before you try that, though, try installing 7.1 one more time and say 'linux
nofb text ide=nodma' and see if that works.  Other than that, I'm pretty much
out of ideas.
Comment 18 lionel azikiwe 2001-05-09 11:20:09 EDT
i will try the new argument linux nofb text ide=nodma later on and update you 
as to the outcome and if all else fails i will then try to upgrade through rpm 
upgradeability.
Comment 19 Brent Fox 2001-05-09 14:09:19 EDT
Ok.
Comment 20 Brent Fox 2001-05-20 13:18:24 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.