Bug 38403 - Installer does not allow one to choose the SCSI adapter in expert and dd mode
Installer does not allow one to choose the SCSI adapter in expert and dd mode
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 12:24 EDT by Mihai Ibanescu
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 14:44:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mihai Ibanescu 2001-04-30 12:24:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)


Related to #38401
When trying to install in expert and/or dd mode, I get the NIC-driver
selection screen, but then it starts loading the AIC driver (which hangs),
without letting me choose the alternate driver. Have to do some magic
aic7xxx=noprobe magic to force it.

Reproducible: Always
Steps to Reproduce:
1. Start installing 7.1 with dd and/or expert
2. Go on with the NIC driver selection
3. Oops, the aic starts to probe...

Actual Results:  Hang.

Expected Results:  I am not given the chance to select the alternate SCSI
driver.

The system is here at meridian, just give me a buzz (x238) to see it for
yourself.
Comment 1 Brent Fox 2001-04-30 12:36:23 EDT
This is a kernel problem.  Changing component.
Comment 2 Brent Fox 2001-04-30 12:36:49 EDT
I've been seeing lots of aic7xxx problems in Bugzilla...
Comment 3 Mihai Ibanescu 2001-04-30 12:42:55 EDT
Is it a kernel bug? Looks like an installer bug to me.
I've already posted #38401 which is definitely kernel-related.
I am not reporting the AIC bug in here, but the strange installer behaviour
(jumping to probe the adaptec driver).
Comment 4 Brent Fox 2001-05-01 18:13:38 EDT
I took a look at this machine...I tried booting it using the boot kernel and the
same thing happens.  Transferring ownership to the kernel team.
Comment 5 Brent Fox 2001-05-01 18:14:16 EDT
Booting the installer with 'linux noprobe' will give you the option of selecting
the drivers.

Note You need to log in before you can comment on or make changes to this bug.