Bug 38406 - Install fails on Proliant 2500 - unable to detect memory (e820), unable to format drive (mke2fs crashes)
Install fails on Proliant 2500 - unable to detect memory (e820), unable to fo...
Status: CLOSED DUPLICATE of bug 36940
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On: 36940
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 12:36 EDT by Bennet Deliduka
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bennet Deliduka 2001-04-30 12:36:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)


All Instances are booting from 7.1 cdrom (floppy behaves the same)
no kernel params - fails; insufficient memory.

linux mem=265M - fails; cannot mount root fs (report errors about loading 
init.img past end of ram... only appears to detect 16meg)

linux mem=exactmap mem=256M@0 - fails; mke2fs crashes system with the 
following trace... (crashes both with auto partition/format and manual 
partition/format)

Hardware is assumed good as 7.0 installs correctly without errors and 
functions normally.

Hardware Descrption:
Compaq Proliant 2500
BIOS: E24 - 12/01/1999 (most current on compaq web site)
RAM: 256Meg
CPU: Dual Pentium 200
Compaq Smart Array 2dh controller
3 4.3 gig drives in mirror w/spare config

Reproducible: Always
Steps to Reproduce:
1. Boot redhat 7.1 cdrom
2. at boot: prompt enter "linux mem=exactmap mem=256M@0"
3. follow any prompts to install system.
error will result when drive is formatted...

other errors will result of the kernel parameter is not included.
(insufficient memory or error mounting root fs)

Actual Results:  Crashed on Install.

Expected Results:  Expected 7.1 to install.
Comment 1 Bennet Deliduka 2001-04-30 12:41:42 EDT
call trace:
c01318cc
c0116a79
c01301ce
c0120ccf
c0120d9d
c0140870
c01330d1
c0133495
c013356f
Comment 2 Bennet Deliduka 2001-04-30 12:42:47 EDT
call trace:
c01318cc
c0116a79
c01301ce
c0120ccf
c0120d9d
c0140870
c01330d1
c0133495
c013356f
c012de96
c01335a3
c0108eaf
Comment 3 Brent Fox 2001-04-30 16:10:48 EDT
Did you burn these cds your self?
Comment 4 Bennet Deliduka 2001-04-30 16:48:24 EDT
Yes, I burned the CDROM's and created the floppies.

Asside from the floppy disks booting much slower than the CDROM the results are 
exactly the same.

boot with no kernel parameters:
only 16 meg detected... 
7.1 refuses to install claiming "not enough memory in this system"

boot with "linux mem=256M"
"
loading initrd.img
.
.
.
initrd extends beyond end of memory (0x0ffffb27 > 0x01000000)
.
.
.
kernel panic: VFS unable to mound root fs on 08:41

I have been working with Matt Wilson who is of the opinion something is wrong 
with how the APIC table is reporting information.  He sent me a custom boot 
disk that indicates that there is no information reported...

I have verified that the system setup software from compaq is set for linux and 
I have tried all three options for the APIC setting (full table - mapped, full 
table, and disabled) with no change in functionality.

If you believe the media is corrupt I will gladly download another copy of the 
boot image for the floppy and perform all of the tests I have done thus far 
again.  If you honestly believe I will get different results with purchased 
commercial media I will start the government PO process to purchase the retail 
product... (usually a long drawn out purchase process due to redhat being a 
sole source for redhat linux...)
Comment 5 Brent Fox 2001-04-30 17:59:49 EDT
Actually, this sounds like more of a kernel problem than anaconda.  Changing
component.
Comment 6 Arjan van de Ven 2001-04-30 18:04:25 EDT
Please try using 255 instead of 256.
The bios tends to "steal" 1Mb of memory
Comment 7 Bennet Deliduka 2001-04-30 19:02:33 EDT
no effect.
nor does removing memory down to 64M and trying from there.
problem is consistent with each of the 4 dimm (should not be physical memory 
problem)

I just tried a 7.0 install followed by a 7.1 upgrade....

things went reasonably well until I got an
pmd not installed
Oops: 0002
.
.
.

I'm figuring at this point that rh 7.1 on a proliant 2500 is not happening in 
the short term...  I'll set asside one of these systems for further testing and 
build the others with 7.0 so I can work on documenting the configuration 
(trying to keep pace with the deployment schedule) 

still open to suggestions for makign 7.1 work...
Comment 8 Need Real Name 2001-05-02 15:20:52 EDT
I get the same errors with the memory.  Compaq Prosignia 500 with 208M and only 
sees 16M.  I installed 7.0 and appended RAM with no plms.  7.1 kernel panics 
with the "append=root".  I have a guy in England with the same problem so its 
not your cd.
Comment 9 Arjan van de Ven 2001-05-11 04:35:44 EDT
Bug 36940 has the commandline option for specifying how much memory you have:

"mem=exactmap mem=0x4000000@0"

would be 64Mb
Comment 10 Bennet Deliduka 2001-05-11 07:29:43 EDT
Does this differ from "mem=exactmap mem=64M@0" ?
Comment 11 Arjan van de Ven 2001-05-11 07:32:12 EDT
The lilo I tried it on didn't like the 64M, but if it works, it's the same.
Comment 12 Niels Kristian Jensen 2001-06-12 09:21:14 EDT
Notice the proposed memory definition line in #36940

It seems you must point out that the memory from 640K to 1M is not regular memory.
Comment 13 Alan Cox 2003-06-06 08:02:31 EDT

*** This bug has been marked as a duplicate of 36940 ***
Comment 14 Red Hat Bugzilla 2006-02-21 13:47:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.