Bug 38430 - Printer driver broken in 7.1 (windoze printer...)
Printer driver broken in 7.1 (windoze printer...)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 14:09 EDT by William W. Austin
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 13:10:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William W. Austin 2001-04-30 14:09:32 EDT
I did a fresh install to 7.1 last week (deluxe set if it matters) and
while nearly everything else works very well, I am having a problem
with printing to a windoze box.

Although my *other* 2 printers -- one PS and one HPPCL -- work fine
on my 7.1 box (both on jetdirect), I cannot successfully print anything
but text to the HP970Cse on my windows box.

(the printer is shared there and the sharing works fine otherwise)

If I go to my 7.0 box, it can print to this printer just fine, AND I can
bring up vmware on my 7.1 box (thanks to the patch posted on the Seawolf
list)
and print postscript or hppcl to it just fine that way.

However after going through the configuration as follows:

        Queue type:           Windows Printer (SMB Share)
        ----------
        Share:                //(machine name)/hp970cse
        Workgroup:            STUPIDITY
        Host IP:              (ip address)
        User:                 (irrelevant -- works same with or without
                              user name/password)
        Password:             (see 'User', above)
        Translate \n => \rn:
                              selected
        Driver:               Deskjet 970Cse or anything else using
                              cdj550 (I have tried several other all
                              using cdj550 -- same results)

        Driver Options:
        --------------
        Set EOT:              Selected
        Rerenderer PS:        (seems irrelevent here -- the results
                              are the same whether selected or not)

        (BTW, I haven't found where the "Rerender" option is documented
        anywhere in the release notes)

Then of course, I apply the changes stopping and restarting lpd.

I also did a manual /etc/rc.d/init.d/lpd restart just to be safe -- no
difference.

I can print text to this printer from my 7.1 box; however, when I try the
button

        Test->Print Postscript Test Page

I get ONLY the top 1/4" of the postscript output -- that is I get the
top of the box down almost to the bottom of the (text) '0.5"' marking
just below that.  Then the page ejects and I start getting garbage pages.

This test works correctly to my other 2 printers here, AND I can
successfully print PS to this printer from my 7.0 box or from vmware --
so I suspect a problem with either setup error or the driver.
Comment 1 redtux 2001-05-09 09:31:03 EDT
I get exactly the same problem with HP1100
Comment 2 Bill McCarty 2001-05-13 19:23:34 EDT
Hmm, I get almost an inch of output on my HP 2100. But, then again, I don't get 
the bonus garbage pages <grin>. I've tried each of the three drivers in the 
database, including ljet4. All worked well until upgrade to 7.1. Printer still 
prints fine from "that other OS," so printer hardware and PCL interpretation 
seem to be ruled out as causes.
Comment 3 Bill McCarty 2001-05-13 19:58:02 EDT
A significant additional observation: connecting the printer directly to the 
Linux host resolves the problem. Data is somehow being mangled during 
transmission to the SMB server. So, the problem is not with the driver, but 
with the transport.
Comment 4 Bill McCarty 2001-05-13 20:05:10 EDT
Duh: Setting translate /n to /r/n to "no" solves my problem. Sorry for any 
inconvenince due to this false lead....
Comment 5 redtux 2001-05-14 08:02:03 EDT
Solved my problem as well
I think it would be useful to post as an errata somewhere, as it is not someting
you would expect to happen IMHO
Comment 6 William W. Austin 2001-05-14 10:50:05 EDT
After a frustrating several days -- had to print out about a dozen
reports/research papers and all had color illustrations in them and would not
print -- I finally (desperation) removed the current LPRng and configuration
tool and installed the 7.0 versions (LPRng-3.6.24-2 and printtool-3.54-1).

Everything now works correctly.

However, I'll go back to the 7.1 rpms tonight and try the translation change
suggested above.

Thanks for the suggestion/info.
Comment 7 William W. Austin 2001-05-15 12:44:07 EDT
I removed the 7.0 printer stuff (LPRng-3.6.24-2, printtool-3.54-1, and
rhs-printfilters-1.81-1) and (just to be safe) removed /var/spool/lpd/* and
/etc/printcap.  I then reinstalled  LPRng-3.7.4-22, printconf-0.2.12-1, and
printconf-gui-0.2.12-1 and re-added my printers but this time setting translate
/n to /r/n to "no"  as described above.

This appears to solve the problem on the deskjet printer.

Thanks for the help, folks, and I *do* agree that this "quirk"  -- if not a bug
outright -- is definitely worth putting into the errata somewhere since if is
the opposite of previous printer configurations from RedHat.
Comment 8 Paul Johnson 2001-06-04 17:20:27 EDT
ascii test page prints, but postscript does not.  print conf seems not able to
remember settings for postscript, as Rerender postscript is unchecked every time
I go back.
Comment 9 Tim Waugh 2002-01-25 12:31:32 EST
Defaults to 'on' in printconf-0.3.62-1.

Note You need to log in before you can comment on or make changes to this bug.