Bug 38449 - Installer crashes when install image is transferred to disk: message says out of disk space but there is 18GB available.
Installer crashes when install image is transferred to disk: message says out...
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-30 15:00 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-08 08:20:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-30 15:00:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Installer crashes when install image is transferred to disk: message says 
out of disk space but there is 18GB available.

Reproducible: Always
Steps to Reproduce:
1.Load CD
2.Reboot machine
3.Go through the setup

Actual Results:  Red Hat will not install.

Expected Results:  Red Hat should install.
Comment 1 Brent Fox 2001-04-30 17:39:58 EDT
At what point does it fail?  Also, it would be very helpful if you could attach
the complete debug message.
Comment 2 Need Real Name 2001-05-01 08:41:59 EDT
Failure happens during install just prior to Figure 4-23 Installing Packages 
from Red Hat 7.1 x86 installation guide: there is an alert box indicating 
creation of file system and formatting, then a progress bar indicating transfer 
of install image. Originally, this progress bar would go about 2/3 of the way 
across the alloted space and then an alert box would appear saying: "An error 
occured during the transfer of the install image. You may be out of disk 
space." Yesterday when talking to support, the progress bar went the full left 
to right length, but the alert appeared anyway. It might be significant that 
there are no % numbers indicating the progress during this step.
Comment 3 Brent Fox 2001-05-01 12:17:49 EDT
If you press <Ctrl><Alt><F3> and <Ctrl><Alt><F4>, do you see any error messages
that might tell you what is happening?
Comment 4 Need Real Name 2001-05-01 12:27:01 EDT
The error messages that I saw were I/O ERRORS refering to SCSI ID5. This would 
be my CDROM device. Strangely, the CDROM drive works fine for loading 7.0 
(which is currently running on this box). Tech support thought it then be 
defective or soiled media, however, my boss brought the installation CDs home 
over the weekend and installed 7.1 on his home machine. He said nothing unusual 
happened during his install.
Comment 5 Brent Fox 2001-05-01 15:02:11 EDT
What kind of cdrom drive is it?
Comment 6 Need Real Name 2001-05-01 15:43:07 EDT
TOSHIBA MODEL: CD-ROM XM-5701 TA Rev:0557 ANSI SCSI revision:02
Comment 7 Brent Fox 2001-05-01 18:36:19 EDT
There is the possibility that the cd is damaged in one spot...the spot that
contains the scsi driver for the cdrom.  It could be that your boss' machine
doesn't have any scsi devices and thus doesn't see the problem.  This seems kind
of unlikely, but you never know.

Are you using automatic partitioning or Disk Druid?
Comment 8 Need Real Name 2001-05-02 08:07:27 EDT
Boss happens to be out of town until Friday, so that will have to wait: I'm not 
sure about his home system.

I installed using the automatic partitioning option.
Comment 9 Brent Fox 2001-05-02 14:48:22 EDT
Hey, try this...when you get to the initial bootup screen, type 'linux
ide=noprobe'.  Does this help?
Comment 10 Need Real Name 2001-05-03 11:03:20 EDT
That worked! Thanks!
Comment 11 Brent Fox 2001-05-03 12:25:23 EDT
Yeah, that has been a problem...the kernel tries to use dma transfers for faster
performance, but some devices just don't like dma.  We're assembling a list of
devices not to use DMA transfers on, and we'll add your cdrom to the list.  Can
you run the command 'cat /proc/ide/hdc/model' where 'hdc' is your cdrom device
name.  It may be hdb, hdd, etc.
Comment 12 Need Real Name 2001-05-03 13:29:10 EDT
I'm not sure I understand: when I run
'cat /proc/ide/hdc/model' (and the variations I'm up to 'hdh')
it returns 'No such file or directory.'
Comment 13 Brent Fox 2001-05-04 10:20:33 EDT
Oh...duh.  Nevermind, you have a SCSI cdrom drive, as you said earlier.  It
should be under something like /proc/scsi/scsi.  What does that say?
Comment 14 Need Real Name 2001-05-04 14:50:49 EDT
Host: Scsi0 Channel: 00 Id: 05 Lun: 00
      Vendor: TOSHIBA Model: CD-ROM XM-5701TA Rev: 0557
      Type: CD-ROM                ANSI SCSI revision: 02
Host: Scsi0 Channel: 00 Id: 06 Lun: 00
      Vendor: IBM Model: DDYS-T1835ON     Rev: S96H
      Type: Direct-Access         ANSI SCSI revision: 03
Comment 15 Brent Fox 2001-05-07 15:31:30 EDT
Ok.  Thanks.  I'm changing component to the kernel.

Arjan, this is another cdrom drive that has dma issues.  If there is something
else you want me to do with these besides assign them to you, please let me know.
Comment 16 Arjan van de Ven 2001-05-08 08:20:47 EDT
This does not look like a DMA issue. Doug: does this ring a bell ?
Comment 17 Doug Ledford 2001-05-08 15:18:27 EDT
Yeah, marginal media and a marginal CD drive.  The ide=nodma is a red herring,
it couldn't have impacted the install at all.  But, the install worked when it
was given, which is simple coincidence that it happened to work when that option
was given, and the real issue is that his CD drive will occasionally fail to
read the CD-ROM.  Most likely, his CD drive is borderline for being able to read
some CDs and his boss' CD drive isn't so borderline.  The CD itself is likely
also borderline about having a bad spot.  It will likely work almost all the
time on his boss' machine and fail a significant portion of the time on his
machine solely due to differences in how well different CD drives can read
marginal CD media.  Not a kernel bug, hardware/media issue.

Note You need to log in before you can comment on or make changes to this bug.