Bug 38453 - Provide formatted version of documentation instead of SGML
Summary: Provide formatted version of documentation instead of SGML
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: wine   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-30 19:22 UTC by Göran Uddeborg
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-30 19:26:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPEC file changes to create HTML documentation (1010 bytes, patch)
2001-04-30 19:24 UTC, Göran Uddeborg
no flags Details | Diff
Correction of a syntax error in a documentation file. (419 bytes, patch)
2001-04-30 19:26 UTC, Göran Uddeborg
no flags Details | Diff

Description Göran Uddeborg 2001-04-30 19:22:08 UTC
In the wine package (wine-20010131-3) the directory "documentation" is
included as documentation of the package.  Most of this directory consists
of DocBook SGML files.  These are not convenient to read, but rather to be
considered documentation source.

I would suggest to rather enclose a formatted version of the
documentation.  Please find enclosed a patch to the spec file which creates
the HTML documentation.  db2html found a syntax error in one of the SGML
files, and I also include a patch for that.  (Used by my modified spec
file.)  That may have been fixed in a newer version of Wine, of course.

My changes package the HTML files INSTEAD of the SGML version.  I also
explicitly point to a few files in the documentation directory which isn't
part of the SGML sources but rather makes sense to include separately.

My choice of HTML version was simply because I find it most convenient. 
You may of course choose to create and package the PDF and/or PS versions
also/instead.  I think it makes sense to send formatted version of the
documentation.  But exactly which format(s) is a matter of taste of course.

Comment 1 Göran Uddeborg 2001-04-30 19:24:33 UTC
Created attachment 16886 [details]
SPEC file changes to create HTML documentation

Comment 2 Göran Uddeborg 2001-04-30 19:26:23 UTC
Created attachment 16887 [details]
Correction of a syntax error in a documentation file.

Comment 3 Bernhard Rosenkraenzer 2001-05-03 16:26:08 UTC
Thanks, done in 20010503-1.



Note You need to log in before you can comment on or make changes to this bug.