Bug 38469 - Kudzu misconfigures IDE ZIP drives
Summary: Kudzu misconfigures IDE ZIP drives
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-30 22:32 UTC by Ted Clark
Modified: 2007-04-18 16:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-01 15:10:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ted Clark 2001-04-30 22:32:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)


Anaconda configured my IDE ZIP drive as /dev/hdd4 in /etc/fstab, and
created the mount point /mnt/zip100.0.  I am using zip discs with an ext2
filesystem, so I changed the entry in /etc/fstab to /dev/hdd, and changed
the mount point to /mnt/zip so its easier to type.  After rebooting the
system, kudzu revoked the /dev/hdd entry in /etc/fstab and added a
/dev/hdd4 entry back in, and it unlinked /mnt/zip and recreated
/mnt/zip100.0.

I tried removing the "kudzu" option from the device line in /etc/fstab, and
this prevented kudzu from revoking the /dev/hdd entry and unlinking
/mnt/zip, but it does not prevent kudzu from adding a  /dev/hdd4 entry to
/etc/fstab, which does not work with discs formatted with the ext2 file
system.

It also appears that invalid device symlinks (/dev/hdd4, in this case) in
$HOME/.gnome-disktop cause Gnome to drop panel properties when rescanning
desktop devices, but this is difficult to reproduce, so I will file a
seperate bug report for it when I get it narrowed down more.

Reproducible: Always
Steps to Reproduce:
1. Add a /dev/hdd entry to /etc/fstab and create /mnt/zip
2. Reboot the system.
	

Actual Results:  The /dev/hdd entry in /etc/fstab is revoked and /mnt/zip
is unlinked.

Expected Results:  /etc/ftab and /mnt/zip should have remained unchanged.

Comment 1 Erik Troan 2001-05-01 14:34:48 UTC
Please try ftp://people.redhat.com/ewt/updfstab.gz


You'll need to:

gunzip updfstab.gz
cp ./updfstab /usr/sbin/updfstab

To see if it works. You can run "updfstab --test" to see the fstab it wants to
output.

Please let me know if this works. I reproduced the problem here w/o any trouble,
and this fixed it.


Comment 2 Ted Clark 2001-05-01 15:10:04 UTC
Yes, this works great.  I uncommented the call to updfstab in
/etc/rc.d/init.d/kudzu and rebooted, /etc/fstab remained unmolested.

Comment 3 Erik Troan 2001-05-01 15:17:28 UTC
Fixed in CVS -- fix will be included in the next build of kudzu.


Note You need to log in before you can comment on or make changes to this bug.