Bug 384731 - Pulseaudio unable to open alsa device with certain Intel hardware
Pulseaudio unable to open alsa device with certain Intel hardware
Status: CLOSED DUPLICATE of bug 370821
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 10:09 EST by Lubomir Kundrak
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 20:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-11-15 10:09:57 EST
Description of problem:

It happens that ordinary user can not launch pulseaudio daemon on certain Intel
hardware (well, I saw it happen on t40 and x31 only, IIRC):

$ pulseaudio 
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_8086_24c5_alsa_playback_0"): initialization failed.
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_8086_24c5_alsa_capture_0"): initialization failed.

Audio devices are owned by root and unwritable by user as per default udev
rules. Pulseaudio daemon is setuid root. When I chmod the audio devices,
pulseaudio can start:

# chmod 777 /dev/snd/*

$ pulseaudio
(works)

I've seen this happen with the following Intel hardware only:
Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)


Version-Release number of selected component (if applicable):

kernel-2.6.23.1-49.fc8
alsa-lib-1.0.15-1.fc8
pulseaudio-0.9.7-0.17.svn20071017.fc8

Additional information:

As this seems hardware/driver dependent, I suspect this might be a bug in alsa,
not pulseaudio. Please reassign if you prove that it is an alsa bug.

If you need strace output or -vvv, just tell me.
Comment 1 Leo Canale 2007-11-16 11:19:05 EST
I'm seeing a same error with Sound Blaster Live card!
Just wanted to be added to the cc list! Thanks.
Comment 2 Bruno RAMEY 2007-11-16 13:39:24 EST
Hi
I have a similar problem with SiS7012 soundcard (driver snd_intel8x0)
and I find a way to make it work .
I change the file /etc/udev/rules.d/40-alsa.rules like this :

# do not edit this file, it will be overwritten on update
KERNEL=="controlC[0-9]*",       NAME="snd/%k", MODE="0666"
KERNEL=="hwC[D0-9]*",           NAME="snd/%k", MODE="0666"
KERNEL=="pcmC[D0-9cp]*",        NAME="snd/%k", MODE="0666"
KERNEL=="midiC[D0-9]*",         NAME="snd/%k", MODE="0666"
KERNEL=="timer",                NAME="snd/%k", MODE="0666"
KERNEL=="seq",                  NAME="snd/%k", MODE="0666"
KERNEL=="mixer0",               SYMLINK+="mixer"
KERNEL=="dsp0",                 SYMLINK+="dsp"
KERNEL=="audio0",               SYMLINK+="audio"

I just had MODE="0666"
Maybe, it's not very clean but it works for me, even after Off/On.
I also delete /tmp/pulse-username directory.
And after Off/on everything was Ok. Alsa and PulseAudio for every user .

Hope it's help !

PS 1 : It's the first time I post in Bugzilla. please tell me if I do something
wrong.
PS 2 : I'm French, So my english ...

Bruno
Comment 3 Lennart Poettering 2007-11-29 20:07:16 EST
Sounds like a duplicate of #370821

*** This bug has been marked as a duplicate of 370821 ***

Note You need to log in before you can comment on or make changes to this bug.