Bug 385 - Can't mount write-protected ext2 floppies
Can't mount write-protected ext2 floppies
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
5.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-11 04:00 EST by hargrove
Modified: 2015-10-14 22:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-19 13:50:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hargrove 1998-12-11 04:00:13 EST
As configured the autofs module for ext2 filesystems will
try to run e2fsck on the filesystem before mounting and
will refuse to mount the filesystem if e2fsck returns an
error code.

However, the current e2fsck (from e2fsprogs-1.12-2) returns
an error if run on write-protected device.  This means that
autofs will fail to mount write proteted floppies when
using a line line:
    ext2-floppy      -fstype=ext2      :/dev/fd0
but will quite happily do the right thing for:
    dos-floppy       -fstype=vfat      :/dev/fd0
or
    auto-floppy      -fstype=auto      :/dev/fd0
This last one, however is less than ideal because it fails
for DOS floppies and doesn't run fsck on ext2 floppies.

The fix would seem to be to check if the device is read-only
before invoking e2fsck, and using the -n option if it is.
Comment 1 Jay Turner 1998-12-11 09:48:59 EST
Yes indeed, when a write-protected disk is attempted to be mounted
with autofs, one gets the error that the mount point does not exist.
Confirmed in test lab.
Comment 2 David Lawrence 1998-12-11 11:46:59 EST
This bug has been assigned to a developer.
Comment 3 Anonymous 1999-05-03 16:44:59 EDT
The two most recent comments (by jturner and dkl on 12/11/1998)
describe the bug as "VERIFIED" and then as "ASSIGNED".  And yet
bugzilla shows a status of "RESOLVED".  Why?

I've just verified that this bug is still present in RHL 6.0
(autofs-3.1.3-2 and e2fsprogs-1.14-4) so I'd not call that resolved.
Comment 4 openshift-github-bot 2015-10-14 22:25:25 EDT
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/0aee001f803e1565c37adc66a7acb61f81086c64
Merge pull request #1068 from bfallonf/issue_385

GH issue #385: added para on logoutURL

Note You need to log in before you can comment on or make changes to this bug.