Bug 385081 - apt-get update parsing errors in /var/lib/apt/lists/download.fedora.redhat(xml file)
apt-get update parsing errors in /var/lib/apt/lists/download.fedora.redhat(xm...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-package-config-apt (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 12:36 EST by Nigel Henry
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 00:38:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Henry 2007-11-15 12:36:29 EST
Description of problem:
Running apt-get update as root results in the following trimmed output.

# apt-get update
Get:1 http://download.fedora.redhat.com fedora/linux/8/i386/os/ repomd.xml 
[418$
86% [1 repomd.xml 3632/4184B 
86%]/var/lib/apt/lists/download.fedora.redhat.com_$
  </head>
         ^

That was from the first run of apt-get update, and was followed by many lines of
parsing errors as below, from a subsequent run of apt-get update.

# apt-get update

/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_8_i386_os_repodata_repomd.xml:20:

parser error : Opening and ending tag mismatch: link line 8 and head
  </head>
         ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_8_i386_os_repodata_repomd.xml:31:

parser error : Opening and ending tag mismatch: img line 31 and a
tic/images/banners/f8-banner-animation.gif" alt="Fedora 8 Werewolf is 
here!"></a
                                                                               ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_8_i386_os_repodata_repomd.xml:32:

parser error : Opening and ending tag mismatch: a line 31 and div
    </div>
          ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_8_i386_os_repodata_repomd.xml:55:

parser error : Specification mandate value for attribute selected
    <option value="en" selected>en</option>
                               ^
<big snip>

       ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_8_i386_os_repodata_repomd.xml:106:

parser error : Premature end of data in tag html line 2
</html>
       ^
E: Could not open metadata file 
'/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_8_i386_os_repodata_repomd.xml'
E: Unable to lock the list directory




Version-Release number of selected component (if applicable):
As on the DVD. (F8 is not booted up at the mo, but if this is important, I'll
find it)


How reproducible:
Always. Also confirmed by someone else on the Fedora list.


Steps to Reproduce:
1.su to root, and run apt-get update
2.
3.
  
Actual results:
As output above.

Expected results:


Additional info:

There is only one repomd URL in /etc/apt/sources.list.d, as at the start of the
posted output above. There is an updates file as well, but it's empty.

The lock file is missing from /var/cache/apt/archives, although the partial
directory is there.
Comment 1 Panu Matilainen 2007-11-16 01:51:34 EST
Doh, the F8 version of fedora-package-config-apt pointed to totally bogus URL's
:-/ Stupid configuration issue, not an apt bug...

Fix built and submitted for update, now we just need to wait for it to get
actually pushed.
Comment 2 Nigel Henry 2007-11-16 14:47:07 EST
Yes. I realised it wasn't a bug last night. Having already having fixed the 
missing lock file problem by copying the one from /var/lib/apt/lists 
to /var/cache/apt/archives, I then overwrote F8's /etc/apt/sources.list with 
that from my F7 install. It had freshrpms, and planetccrma in it. Ran apt-get 
update again, which still didn't work. Then commented out that URL that's 
going nowhere, and ran apt-get update again, and it all worked like clockwork. 
As Apt was now working ok, I overwrote the 2 Fedora files 
in /etc/apt/sources.list.d with the corresponding ones from my F7 install, and 
again, an apt-get update ran to completion, with a few more updates available. 
 
Regarding the missing lockfile in /var/cache/apt/archives Panu. When is this 
supposed to be created? I'd already copied the lockfile 
from /var/lib/apt/lists to the archives directory. Is it supposed to be 
created when you install Apt, or only after a first successfull run of apt-get 
update? 
 
If neither, there may still be a problem with the missing lockfile in the 
archives directory, but I'm presuming you have fixed that too. Feedback 
appreciated. 
 
Thanks for your work with Apt. I've use it since FC1. 
 
Nigel. 
Comment 3 Fedora Update System 2007-11-17 00:38:23 EST
fedora-package-config-apt-8-1 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.