This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 385241 - feature request: update vnc-server
feature request: update vnc-server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vnc (Show other bugs)
5.1
All Linux
high Severity high
: ---
: ---
Assigned To: Adam Tkac
: FutureFeature, Rebase
Depends On:
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2007-11-15 13:45 EST by Joshua Daniel Franklin
Modified: 2013-04-30 19:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
vnc-server is now re-based to Fedora 7 version and RHEL 5.3 X.Org server. This update applies the following fixes and enhancements: - A bug that prevented vncserver from printing error messages when Xvnc failed to start is now fixed. - Xvnc no longer uses the wrong root window depth; it now uses the correct window depth specified by the -depth option. - A bug that causes the libvnc.so module to crash the X server is now fixed. - Xvnc now supports GLX and RENDER extensions on all architectures.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:15:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua Daniel Franklin 2007-11-15 13:45:53 EST
Description of problem:
We had a small issue that an EL5 user wanted to use a GLX-aware
research application (MedINRIA) over VNC. Although we were not
actually using the 3D parts of the app, it crashes because
vnc-server does not enable GLX. However, I found that the
Fedora 7 package vnc-server-4.1.2-14.fc7 which is slightly 
newer does enable GLX and the app runs fine on Fedora 7. I
would like to request a newer vnc-server in the
next EL5 update (maybe 5.2).

Version-Release number of selected component (if applicable):
vnc-server-4.1.2-9.el5
Comment 1 Adam Tkac 2007-11-16 04:44:24 EST
(In reply to comment #0)
> Description of problem:
> We had a small issue that an EL5 user wanted to use a GLX-aware
> research application (MedINRIA) over VNC. Although we were not
> actually using the 3D parts of the app, it crashes because
> vnc-server does not enable GLX. However, I found that the
> Fedora 7 package vnc-server-4.1.2-14.fc7 which is slightly 
> newer does enable GLX and the app runs fine on Fedora 7. I
> would like to request a newer vnc-server in the
> next EL5 update (maybe 5.2).
> 
> Version-Release number of selected component (if applicable):
> vnc-server-4.1.2-9.el5

Yes, we will speak about rebase to vnc from F7 or F8 because it is far more
stable that RHEL5 version. Approved component list to 5.2 is already closed so I
will try update vnc in 5.3
Comment 2 Daniel Riek 2008-07-17 10:23:20 EDT
PM ACK
Comment 11 Don Domingo 2008-11-11 21:44:09 EST
this bug fix is now documented in the RHEL5.3 release notes (Resolved Issues).

please refer to the following link within the next 24 hours or so to view the most current build:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.3/html-single/Release_Notes/
Comment 12 Don Domingo 2008-11-11 21:44:09 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
vnc-server is now re-based to version 4.1.2-14.el5. This update applies the following fixes:

- A bug that prevented vncserver from printing error messages when Xvnc failed to start is now fixed.
- Xvnc no longer uses the wrong root window depth; it now uses the correct window depth specified by the -depth option.
- A bug that causes the libvnc.so module to crash the X server (when dri and glx modules are specified in xorg.conf) is now fixed.
- Xvnc now supports GLX and RENDER extensions on all architectures.
Comment 14 Adam Tkac 2008-11-24 06:16:53 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,6 +1,6 @@
-vnc-server is now re-based to version 4.1.2-14.el5. This update applies the following fixes:
+vnc-server is now re-based to Fedora 7 version and RHEL 5.3 X.Org server. This update applies the following fixes and enhancements:
 
 - A bug that prevented vncserver from printing error messages when Xvnc failed to start is now fixed.
 - Xvnc no longer uses the wrong root window depth; it now uses the correct window depth specified by the -depth option.
-- A bug that causes the libvnc.so module to crash the X server (when dri and glx modules are specified in xorg.conf) is now fixed.
+- A bug that causes the libvnc.so module to crash the X server is now fixed.
 - Xvnc now supports GLX and RENDER extensions on all architectures.
Comment 15 Don Domingo 2008-11-24 17:54:49 EST
note revised as specified. thanks Adam.
Comment 17 errata-xmlrpc 2009-01-20 16:15:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0119.html

Note You need to log in before you can comment on or make changes to this bug.