Bug 38530 - Running XFree86 4.0.3 gives blank screen with FPD1500 monitor and radeon SDR video card
Running XFree86 4.0.3 gives blank screen with FPD1500 monitor and radeon SDR ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-01 01:13 EDT by Caroline A. Scolari
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-16 05:26:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result of lspci -v (3.54 KB, text/plain)
2001-05-08 01:40 EDT, Caroline A. Scolari
no flags Details
Result of lspci -vn (2.65 KB, text/plain)
2001-05-08 01:42 EDT, Caroline A. Scolari
no flags Details
XF85Config-4 (1.80 KB, text/plain)
2001-05-08 01:44 EDT, Caroline A. Scolari
no flags Details
XFree86.0.log - XFree86 log file 1 (24.58 KB, text/plain)
2001-05-08 01:45 EDT, Caroline A. Scolari
no flags Details
XFree86.9.log - XFree86 log file 2 (previous try, I believe) (25.29 KB, text/plain)
2001-05-08 01:46 EDT, Caroline A. Scolari
no flags Details

  None (edit)
Description Caroline A. Scolari 2001-05-01 01:13:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


I worked with a person at Red Hat on this problem this A.M. trying to 
start XFree86 version 4.0.3, with no success. 

During installation, the Red Hat installation program found the Radeon AGP 
SDR card and Gateway FPD1500 monitor, and an imperfect X screen desktop 
(screen with some distortion around text items) could be seen. However, 
after the initial install program, attempts to run XFree86 failed with a 
blank screen.  We ran Xconfigurator, and during all configuration tests, 
XFree86 yields a blank screen also. The Red Hat rep. checked the horizonal 
sync and vertical sync. of the FPD1500 monitor and gave me slightly 
corrected values to try, as well as double-checking that the color was 16 
bit and the screen resolution 1024x768. These did not solve the problem.   
We also double-checked that Option "nodri" was set (it was).

On running modprobe -d radeon, modprobe failed with the error 
message "cannot initialize agpgart module".  On running modprobe -d 
agpgart does not give an error message, and subsequent calls to modprobe -
d radeon also did not cause an error.  After the modprobes, we again tried 
to start X, again without success.


Reproducible: Always
Steps to Reproduce:
1.Use either installation routine or Xconfigurator to configure card
2.In Xconfigurator, do not get an acceptable configuration, with 
occasional lock-up
3.Otherwise, type startx. About half of the time I can get back to the 
command-line using <Ctrl>-<Alt>-<Backspace>, the other half of the time 
only a reboot will bring back the screen.
	

Actual Results:  Blank screen with screen status light changed to yellow 
(normally power save or computer off status). If in Xconfigurator, the 
screen sometimes will return with the message that the configuration is 
not good.  As mentioned above, when trying startx, about half of the time 
I can get back to the command-line using <Ctrl>-<Alt>-<Backspace>, the 
other hold of the time it's locked up totally.

Thank you in advance.
Comment 1 Mike A. Harris 2001-05-07 02:32:55 EDT
You should not use modprobe at all for any video card.  XFree86 will
automatically modprobe any kernel DRM modules on its own, as well as
agpgart.  The Radeon 3D is not supported at all, and so any radeon.o
kernel module should _never_ be loaded.

Is this a Radeon VE card by chance?  Please supply your XF86Config-4
and X server logs as file attachments using the "Create a new attachment"
link below.  Also, I will need the output of "lspci -v" as well as
"lspci -vn" to analyze the PCI ID's.
Comment 2 Caroline A. Scolari 2001-05-08 01:40:16 EDT
Created attachment 17647 [details]
result of lspci -v
Comment 3 Caroline A. Scolari 2001-05-08 01:42:36 EDT
Created attachment 17648 [details]
Result of lspci -vn
Comment 4 Caroline A. Scolari 2001-05-08 01:44:17 EDT
Created attachment 17649 [details]
XF85Config-4
Comment 5 Caroline A. Scolari 2001-05-08 01:45:20 EDT
Created attachment 17650 [details]
XFree86.0.log -  XFree86 log file 1
Comment 6 Caroline A. Scolari 2001-05-08 01:46:15 EDT
Created attachment 17651 [details]
XFree86.9.log - XFree86 log file 2 (previous try, I believe)
Comment 7 Caroline A. Scolari 2001-05-08 01:51:23 EDT
Hi.  I believe that I have attached the information that you have requested.  
To the best of my knowledge, the card is a Radeon AGP QD.  Please let me know 
if you require more or different information, and thank you again for looking 
at this.

Caroline
P.S. The file really is XFree86Config-4.  Sorry for the typo on the label
Comment 8 Panic 2001-06-04 17:03:17 EDT
Another customer is having a similar problem.  The primary ID is 0x1002 (ATI)
0x5144 (Radeon), subsystem ID is 0538.  Xconfigurator works, detects things
correctly, displays a black screen on testing.  He has an SPD(FPD?)1800
flat-panel display hooked up to the DVI port.
Comment 9 Mike A. Harris 2002-05-13 19:30:07 EDT
Does XFree86 4.2.0 in Red Hat Linux 7.3 still exhibit this problem?
Comment 10 Mike A. Harris 2002-07-16 05:26:02 EDT
ping
Comment 11 Mike A. Harris 2002-07-26 06:41:37 EDT
Closing CURRENTRELEASE.  If the problem persists in Red Hat Linux 7.3
with all erratum applied, feel free to reopen and I'll look into this
again.

Note You need to log in before you can comment on or make changes to this bug.