Bug 38538 - nullpointer error during filesystem check
nullpointer error during filesystem check
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-01 07:53 EDT by Tom Eugelink
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 13:37:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Eugelink 2001-05-01 07:53:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


After a clean install of RedHat 7.1 on a P2@233Mhz, Asus MB, IBM 15GB HD, 
Riva128 (more hardware specs can be provided if required) the system 
performed a correct boot to KDE. It then blocked from some reason and a 
hard reset was required (no further information on the reason of the 
block).

During the fschk of /home the system reports a nullpointer error 
and "tried to kill init". The system then freezes. 

The behaviour reoccurs after a clean reinstall.


Reproducible: Always
Steps to Reproduce:
1. start the computer
2.
3.
	

Actual Results:  Screen dump of the nullpointer error with "tried to kill 
init" message

Expected Results:  fschk should have completed and the boot should have 
continued as it did the first time.
Comment 1 Arjan van de Ven 2001-05-01 08:10:57 EDT
The most useful information for me at this time is "lspci" output.
Or at least more information about the exact motherboard (which would
allow me to get the same info) would be appreciated.
Comment 2 Tom Eugelink 2001-05-02 00:03:10 EDT
Since RedHat never reaches a state where I can input commands, I cannot run 
lspci. The MB is Asus P2L97. The system in an extended form (ZIP, CDWriter, 
etc) has run Windows including W2K without problems for over three years.
Comment 3 Arjan van de Ven 2001-05-02 07:01:05 EDT
Do you have some sort of soundcard ?
Comment 4 Tom Eugelink 2001-06-29 01:30:43 EDT
I've switched from RedHat 7.1 to Suse 7.2. Installed and runs flawlessly. DHCP 
server, webserver, SMB. 

Got myself a new copy of RedHat7.1 which has been installed on another system 
and runs correctly on that system. Reinstalled that on my system. 

Similar problem: stuck somewhere in X, reboot, file system checks ok this time, 
after "INIT: entering runlevel: 5", 
it reports "unable to handle kernel NULL pointer dereference at virtual address 
00000d00, printing eip".

In the EIP dump: "pmd entry c13d4000: 000000000000 ... pdm not present! Oops: 
0002" and it is a gonner...

Maybe this will help.
Comment 5 Tom Eugelink 2001-07-10 03:33:38 EDT
Yes, I do have a soundblaster 128 installed. I reinstalled RedHat 7.1 and not 
let it configure the soundcard (it is found during the hardware detection). 
Still crashing.

Mandrake 8.0 also runs flawlessly. As I understand Mandrake is RedHat 
compatible. Hence I'm sticking to Mandrake for now.

Note You need to log in before you can comment on or make changes to this bug.