Bug 38539 - 7.1 installer chokes on RPMs from RedHat 6.2
7.1 installer chokes on RPMs from RedHat 6.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-01 07:55 EDT by Henning Schmiedehausen
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-01 10:02:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump from the crash as described above. (9.88 KB, text/plain)
2001-05-01 07:56 EDT, Henning Schmiedehausen
no flags Details

  None (edit)
Description Henning Schmiedehausen 2001-05-01 07:55:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-1t i686)


This report is related to Bug # 38537. As the normal RedHat 6.2
installation process
is no longer usable with the newer RPMs from ftp.redhat.com, I tried to use
the much
improved installer from RH 7.1 to install the 6.2 RPMs.

I prepared a tree with the following structure:

-- RedHat ----+------ RPMS   - all RPMs from the 6.2 CD + all upgrade from
                         |                            ftp.redhat.com
                         +------ base     - .img Files from the seawolf CD
#1,
                                                       hdlist file created
from the RPMs above with
                                                        genhdlist
                                                        comps file from the
RedHat 6.2 base directory

All this is accessible over FTP as I wanted to use this for a network
install. The
install worked really fine, up to software selection, I selected all wanted
packages,
the installer started to format the file systems and then crashed with a
python 
backtrace. I've written the anacdump.txt file and will attach it to this
bug report



Reproducible: Always
Steps to Reproduce:
1. create an RedHat install tree as described above. 
2. create a bootnet.img floppy from the RH 7.1 CD
3. boot, install from network as described. 
	

Actual Results:  Crashed with an internal python error.	

Expected Results:  Should install, the newer installer should cope with
older RPMs
Comment 1 Henning Schmiedehausen 2001-05-01 07:56:47 EDT
Created attachment 16966 [details]
anacdump from the crash as described above.
Comment 2 Henning Schmiedehausen 2001-05-01 10:01:59 EDT
Ok, I was able to resolve this by using the genhdlist tool from the anaconda-7.1
package. This
now works fine; two quirks stay: you need the lilo from 7.1 (for /boot/message)
and the e2progs
from 7.1 or you won't be able to mount your filesystems because 1.18 from 6.2
doesn't grok
labels. Maybe make two upgrade packages for this?

Note You need to log in before you can comment on or make changes to this bug.