Bug 38541 - Printer-config doesn't work
Printer-config doesn't work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-01 08:26 EDT by Karl F. Larsen
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-26 02:30:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl F. Larsen 2001-05-01 08:26:45 EDT
I loaded 7.1 and used printer-config and it worked. After about a week I
tried to print something to my Local laserjet and it failed. Using lpq I
found that lpd is trying to send my print job to a remote printer on
localbus!  I brought up printer-config and it looked right, at least
indicated a "local" printer.

I deleted the entery and re-loaded it. The gui thing was happy but it still
doesn't print. I looked at man lpr and was scared to death! That has been
re-written into a bear of a thing to set up! I suppose it's better for
automated devices.....

I have re-loaded the printer 4 more times and even tried to get aps4 to
work.  At this point I cannot print from version 7.1, but version 6.1 still
works fine.
Comment 1 Bernhard Rosenkraenzer 2001-05-01 08:45:38 EDT
We never shipped printer-config (it was part of rawhide some time between 6.1 
and 6.2); assuming you mean printconf and reassigning.
Comment 2 Karl F. Larsen 2001-05-01 10:36:39 EDT
Sorry, I'm talking about the printer configuration tool that you bring up in
Gnome that is exactly named "Printer Configuration". I click on that, a panel
comes up asking for root password and then a dialog box comes up where you can
click help and it tells you how to set up a local printer.. I have re-done this
many times and it now will not work. It did work for less than a week.
Comment 3 Karl F. Larsen 2001-05-01 17:39:56 EDT
Well after recalling that I changed the hostname of my computer to my own from
what you ship it as and that's when printing stopped working. I used linuxconf
to change the hostname and that may not be the right way to do it, but it's NOT
covered in any Red Hat Manual.

So a few minutes ago I went back and re-did the linuxconfig networking hostname
thing with more completeness. I made up an ip number and name to make
cannac@ampr.org 44.30.2.5 which I put in the proper places. I did NOT activate
the listing and put none after kernel drivers ect. I then made sure that
linuxconf did the proper thing and my printing is odd compared to Red Hat 6.1
but it now works to a local printer. 

I'm a long time linux user. This problem I think will cause many new users a
problem if they try to re-set the computer hostname. You need to re-create this
problem and find a solution.  kfl
Comment 4 Anthony van Leeuwen 2001-06-05 13:23:35 EDT
On one system, I was able to flawlessly install a laserjet 4 printer using the gui.  On a different system, also loaded with Red Hat 7.1, I was unable to 
to install an HP DeskJet 780Cxi printer.  It seems that the printer configuration files in /etc, i.e. printcap and printcap.local are unchanged after use of the 
gui.  As a result, lpd detects no printers are defined, and printing a test page from the gui results in an error message that the program was unable
to connect with localhost most likely because lpd is not running.

I checked my printer interface to /dev/lp0 by using a series of command such as:  echo "string" > /dev/lp0 and was able to get the printer to print a page. 
 So the interface to the printer is functioning.

Comment 5 Phil Moors 2001-09-26 02:30:23 EDT
Hmmm. /etc/printcap is unchanged and you get an error message. See bugzilla
#53766. You may need to install the perl package.

Note You need to log in before you can comment on or make changes to this bug.