Bug 385431 - toshiba_acpi doesn't get loaded automatically
toshiba_acpi doesn't get loaded automatically
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 14:58 EST by Radek Bíba
Modified: 2008-01-27 15:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-27 15:25:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode output (10.29 KB, text/plain)
2007-11-29 14:17 EST, Radek Bíba
no flags Details

  None (edit)
Description Radek Bíba 2007-11-15 14:58:27 EST
Description of problem:
Previously, the toshiba_acpi kernel module was automatically loaded on my
Toshiba A50 laptop during system start-up. This is not the case with Fedora 8
anymore. I can modprobe it manually so it's not a sudden hardware problem.

This is pretty annoying since this module is needed to control screen
brightness, video switching, hotkeys and other cool stuff.

Version-Release number of selected component (if applicable):
hwdata-0.207-2.fc8
kernel-2.6.23.1-49.fc8
...and other up-to-date F8 packages

Additional info:
Not sure where the root cause is, just trying hwdata :)
Comment 1 Florian La Roche 2007-11-18 05:39:39 EST
This used to get loaded from rc.sysinit in initscripts in the past, but was
removed from there. Probably real fix is to change the kernel to make sure it
gets loaded.

Not something for hwdata to fix, please open a new request against
kernel or initscripts to get this fixed up.

regards,

Florian La Roche
Comment 2 Radek Bíba 2007-11-21 04:46:10 EST
Reopening rather than creating a new one...
Comment 3 Radek Bíba 2007-11-21 04:46:51 EST
Okay, reassigning to initscripts. I don't see any reason why vendor-specific
kernel modules shouldn't be auto-loaded anymore.
Comment 4 Bill Nottingham 2007-11-21 10:47:47 EST
This is a kernel bug; the module needs to provide the proper DMI aliases.
Comment 5 Dave Jones 2007-11-27 18:42:54 EST
attach dmidecode output please.
Comment 6 Radek Bíba 2007-11-29 14:17:41 EST
Created attachment 273191 [details]
dmidecode output
Comment 7 Radek Bíba 2007-11-29 14:18:14 EST
Attached.
Comment 8 Christopher Brown 2008-01-23 18:37:00 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 9 Radek Bíba 2008-01-24 02:50:41 EST
Hi Chris,

I worked around this issue by modprobe'ing toshiba_acpi in /etc/rc.d/rc.local,
which is, ehm, ugly, but works :) . I can definitely try to nuke this hack and
reboot and see if this problem still exists or not. I hope it wait for some
time, you know, since hibernating works great on my laptop, I don't really
reboot it too often.
Comment 10 Christopher Brown 2008-01-24 04:26:01 EST
If you can test, maybe with 2.6.24 when it arrives that would be good...
Comment 11 Radek Bíba 2008-01-27 15:25:30 EST
I actually think I'm lame. Is the kernel module really supposed to be loaded
automatically? What I didn't write in comment 0 was that I was using fnfx
previously, but I didn't have it installed when I installed F8, started working
with it, and hit this "bug". Then I installed it again (and also set up the
rc.local hack), and everything was OK. No wonder, the fnfx init script loads
toshiba_acpi when it's not yet loaded...

Not sure about the question I just wrote, but I guess the answer isn't really
"Yes". Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.