Bug 385971 - zsh isn't working with scp properly
zsh isn't working with scp properly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 18:34 EST by Josef Bacik
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 01:23:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Bacik 2007-11-15 18:34:04 EST
Description of problem:
scp doesn't work when you use an * in the filename, zsh complains about not
being able to find the command.


Version-Release number of selected component (if applicable):
zsh-4.3.4-4.fc8.ppc

How reproducible:
everytime

Steps to Reproduce:
1.scp user@host:~/blah* .
  
Actual results:
You get something like this

ÚÄ(josef@localhost)Ä(651/pts/3)Ä(06:35pm:11/15/07)Ä-
ÀÄ(%:~)Ä- scp josef@dhcp243-37.rdu.redhat.com:~/Josef* .  
zsh: no matches found: josef@dhcp243-37.rdu.redhat.com:~/Josef*

Expected results:
It should download the files.

Additional info:
I ran the same thing in bash and it worked properly.
Comment 1 James Antill 2007-11-16 01:23:59 EST
 You have the nomatch option set. See the man page for NOMATCH and CSH_NULL_GLOB.

 Hint: you probably want: setopt NO_NOMATCH

Note You need to log in before you can comment on or make changes to this bug.