Bug 386011 - Broken driver on ATI Mobility Radeon X300
Broken driver on ATI Mobility Radeon X300
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 18:46 EST by Scott Schmit
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 10:23:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
generated xorg.conf (1.32 KB, application/octet-stream)
2007-11-20 19:01 EST, Scott Schmit
no flags Details
Xorg.0.log after doing an init 5 followed by init 3 (46.48 KB, application/octet-stream)
2007-11-20 19:04 EST, Scott Schmit
no flags Details
Xorg.0.log with no xorg.conf and startx (47.97 KB, application/octet-stream)
2007-11-20 19:06 EST, Scott Schmit
no flags Details

  None (edit)
Description Scott Schmit 2007-11-15 18:46:56 EST
Description of problem:
At any resolution, when X starts, it starts out dark--sometimes with
"nifty"-looking spashes of purple/blue/white color--and gradually brightens
until the screen is a dark gray with two thin vertical bands of lighter gray at
(if you imagine the screen divided into 5 parts) part 2 and 4 of 5. The splashes
of color, if any, stay present throughout. It then stays this way.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.7.195-3.fc8

How reproducible:
Every time. Tried reconfiguring with system-config-display --reconfig, tried
various resolutions, no change to behavior. Using the vesa driver instead works.

Steps to Reproduce:
1. system-config-display --reconfig on a ATI Radeon Mobility X300. I happen to
have a laptop LCD panel 1920x1200.
2. Start X
3. 
  
Actual results:
See a messed up display, as described above.

Expected results:
X should Just Work (TM), just like it did in Fedora 7.

Additional info:
This is a Dell Inspiron 6000 laptop. This bug forced me to text mode install, as
it also affects the installer.
Comment 1 Matěj Cepl 2007-11-19 11:05:39 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Scott Schmit 2007-11-20 19:01:51 EST
Created attachment 265551 [details]
generated xorg.conf

xorg.conf after system-config-display --reconfig and setting LCD panel type to
1920x1200
Comment 3 Scott Schmit 2007-11-20 19:04:28 EST
Created attachment 265561 [details]
Xorg.0.log after doing an init 5 followed by init 3

To my surprise (considering what happens when I do system-config-display with
this xorg.conf in place), this actually worked as expected. Startx works as
well.
Comment 4 Scott Schmit 2007-11-20 19:06:30 EST
Created attachment 265571 [details]
Xorg.0.log with no xorg.conf and startx

This also worked as expected.
Comment 5 Scott Schmit 2007-11-20 19:10:54 EST
The Xorg.setup.log that's generated when I run system-config-display has zero
length.

When I kill the X display (Control-Alt-Backspace) after it's hosed, this is
printed on the display:
xconf.py: Fatal IO error 11 (Resource temporarily unavailable) on X server :17.0.
Window manager warning: Fatal IO error 0 (Success) on display ':17.0'.

I suspect that's entirely due to X being killed, but just in case...
Comment 6 Dave Airlie 2007-11-29 22:28:29 EST
is there still a bug here? or does it work had to tell..

if still buggy, please re-test with latest ATI driver in updates-testing...
Comment 7 Matěj Cepl 2008-01-15 12:20:40 EST
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 8 Matěj Cepl 2008-02-15 10:23:52 EST
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.