Bug 386081 - The listSystemEvents XMLRPC call is incorrectly documented
Summary: The listSystemEvents XMLRPC call is incorrectly documented
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
(Show other bugs)
Version: rhn505
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Sebastian Skracic
QA Contact: Red Hat Network Quality Assurance
URL: https://rhn.redhat.com/rhn/apidoc/sys...
Whiteboard: US =29983
Keywords:
: 459447 541054 (view as bug list)
Depends On:
Blocks: 428922 rhn-sprint30
TreeView+ depends on / blocked
 
Reported: 2007-11-16 01:08 UTC by Andrew Ryan
Modified: 2018-10-19 23:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-17 23:26:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Robinson 2007-11-16 01:08:54 UTC
Description of problem:
The listSystemEvents XMLRPC call is incorrectly documented. Its a copy & paste
of the second listUserSystems method ("List systems for the logged in user").

The incorrect call is here:
https://rhn.redhat.com/rhn/apidoc/system/SystemHandler.jsp#listSystemEvents

and its a copy of the second listSystemEvents call here:
https://rhn.redhat.com/rhn/apidoc/system/SystemHandler.jsp#listUserSystems

Version-Release number of selected component (if applicable):
Affects current RHN (5.0.3) and probably (I haven't confirmed) the latest RHN
Satellite release.

Expected results:
The API documentation should match the API.

Comment 3 Amy Owens 2008-06-10 15:00:51 UTC
added user story

Comment 5 Amy Owens 2008-08-19 12:56:20 UTC
*** Bug 459447 has been marked as a duplicate of this bug. ***

Comment 7 Sebastian Skracic 2009-08-25 14:15:14 UTC
This API call has now been implemented with proper apidoc.  Change
d03f8ec4d267767e3f2d7211f263c08dcb6a1d49.

Comment 8 Denise Hughes 2009-08-27 14:46:16 UTC
No results returned.

At command line, type:
python callAnyMethod.py dhughesgit redhat system.listSystemEvents 1014361596

Results:

========================================
Calling: system.listSystemEvents
With args:
[1014361596]
========================================
Returned:
[]

Comment 9 Sebastian Skracic 2009-08-28 08:34:23 UTC
(In reply to comment #8)
> No results returned.
> 
> At command line, type:
> python callAnyMethod.py dhughesgit redhat system.listSystemEvents 1014361596
> 
> Results:
> 
> ========================================
> Calling: system.listSystemEvents
> With args:
> [1014361596]
> ========================================
> Returned:
> []  

  This is because system ID 1014361596 had no scheduled actions in its history.  You should try querying for any system that had at least one scheduled action, no matter how successful their execution was.  For example:

1013803204 - should list 'Package Install' action
1012685555 - should list 105 events
etc
...

Comment 10 Denise Hughes 2009-09-11 19:20:33 UTC
Verified on webdev

	
Testopia ID:
https://testopia.devel.redhat.com/bugzilla/tr_show_case.cgi?case_id=12032

Comment 11 James Bowes 2009-11-26 16:47:14 UTC
*** Bug 541054 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.