Bug 38609 - xdvi core dumps when reading dvi-file while latex is compiling
xdvi core dumps when reading dvi-file while latex is compiling
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-01 13:40 EDT by Finn Aarup Nielsen
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-30 18:32:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Finn Aarup Nielsen 2001-05-01 13:40:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


xdvi makes a segmentation fault after it has read a DVI-file unsuccesfully
and the xdvi window has been focused two times. An unsuccesful read appear
when latex is compiling a tex-file to a DVI-file (xdvi reports it as "DVI
file corrupted").

Reproducible: Always
Steps to Reproduce:
1. latex largefile.tex
2. xdvi largefile.dvi
3. latex largefile.tex
4. (while latex is running) Mouse focus in xdvi -> "DVI file corrupted"
(normal behavior)
5. Mouse unfocus xdvi 
6. Mouse focus in xdvi -> "segmentation fault"
	

Actual Results:  xdvi core dumps

Expected Results:  xdvi should stay open (not crash). Reporting "DVI file
corrupted" is expected. 

Not a problem with Redhat 7.0 and 6.2
Comment 1 Tim Waugh 2001-09-26 09:06:17 EDT
I expect that this is sensitive to the exact stage of processing the file.  
Can you supply a partially-generated DVI file that exhibits this behaviour?
Comment 2 Need Real Name 2001-09-27 19:08:37 EDT
The .dvi file is empty while latex is running.

$ xdvi some.dvi &
$ > some.dvi
Two clicks on "Reread" and xdvi crashes with a "segmentation fault".
Comment 3 Tim Waugh 2001-09-30 17:11:10 EDT
It works fine for me here.  Perhaps it depends on the original DVI file 
'some.dvi'. (I used the printconf test page DVI file.)
Comment 4 Need Real Name 2001-09-30 18:32:34 EDT
I have this problem with all DVI files.

$ rpm -qf `which xdvi.bin`
tetex-xdvi-1.0.7-15
$ cp /usr/share/printconf/tests/testpage.dvi .
$ xdvi.bin testpage.dvi &
# Everything works fine.
$ > testpage.dvi 
# First click on "Reread" -> "Not a DVI file."
# Second click on "Reread" -> "segmentation fault"
Comment 5 Tim Waugh 2001-10-01 05:38:35 EDT
Okay, I can reproduce this with tetex-1.0.7-15.  This seems to be already 
fixed in tetex-1.0.7-32, but I'm not sure which change fixed it.

Note You need to log in before you can comment on or make changes to this bug.