Bug 386171 - Miro 0.9.9.9 will not start
Summary: Miro 0.9.9.9 will not start
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro   
(Show other bugs)
Version: 8
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Thorsten Scherf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-16 02:59 UTC by Steve Fox
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 04:57:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Fox 2007-11-16 02:59:11 UTC
Description of problem:

Miro will not start. It gives the Python traceback:

Traceback (most recent call last):
  File "/usr/bin/miro.real", line 119, in <module>
    iface.HandleArgs(dbusargs)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 63, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 135, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 603, in
call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.AttributeError:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/dbus/service.py", line 655, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib64/python2.5/site-packages/miro/onetime.py", line 125, in HandleArgs
    dbus.service.Object.__init__(self, bus_name,
'/org/participatoryculture/dtv/OneTime')
AttributeError: 'NoneType' object has no attribute 'widgetTree'

This happens with an existing .miro directory as well as without any
pre-existing configuration.

Version-Release number of selected component (if applicable):

Miro-0.9.9.9-1.fc8
How reproducible:

always

Steps to Reproduce:
1. run 'miro' from a terminal

Comment 1 Alex Lancaster 2007-11-16 07:23:12 UTC
I can't reproduce this on my F-8 machine, it starts just fine for me. I'm
running i386, perhaps that might account for the difference.

I'm planning to upgrade to 1.0 soon (bug #380811), I'll check to see if any
python/d-bus related bugs have been fixed since 0.9.9.9

Comment 2 Steve Fox 2007-11-21 04:34:47 UTC
Unfortunately, I get the same error with Miro-1.0-1.fc8.

Comment 3 Steve Fox 2007-11-21 04:57:27 UTC
Okay, I dug around in the source a bit, trying to figure out what's going on. It
turns out that I had a stale miro process running and Miro's "OneTime" class
apparently has a bug in it. Killing the stale process fixed it. 


Note You need to log in before you can comment on or make changes to this bug.