Bug 386181 - Difficult finding the *real* hardware mixer
Difficult finding the *real* hardware mixer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 22:07 EST by Linus Torvalds
Modified: 2008-09-09 18:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 18:55:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linus Torvalds 2007-11-15 22:07:17 EST
Description of problem:
I like the concept of pulseaudio, but it almost totally hides the real hardware
mixer. On several of my machines, I need to make sure that the mixer values are
right (ie front speaker isn't muted or something), and pulseaudio is a real step
backwards. Running "alsamixer" only shows the pulseaudio volume, as does the
graphical thing in the taskbar, etc etc etc.


Version-Release number of selected component (if applicable):
Current fedora 8

How reproducible:
Entirely

Steps to Reproduce:
1. No sound
2. Try to fix it with a mixer
3. Fail. No profit!
  
Actual results:
I finally realized that I can do "alsamixer -c0" and get it, but that was after
I had fixed the hardware mixing by
 - remove pulseaudio entirely (because sound didn't work)
 - fix the volumes with alsamixer
 - re-install pulseaudio (now sound works, because the hw mixing setup was done
correctly)

Expected results:
Some obvious in-your-face way to actually set the actual hardware mixer
controls. The taskbar should have stayed with the hardware or something!

Additional info:
Maybe what I ask for exists, but it sure ain't obvious. Making all the mixer
interfaces just go to pulseaudio seems to have been a mistake.
Comment 1 Lennart Poettering 2007-11-29 19:39:25 EST
You can always fiddle with the raw mixer settings with "alsamixer -c0",
regardless of PA is installed or not.

It is a big mess that currently we have three volume controls in a series on
machines like the Thinkpads: the "PCM" slider, the "Master" slider, and the real
hardware volume up/down buttons. The plan is to initialize them all to "sane"
defaults" and expose only a single of them in the UI. This has partially been
implemented in F8. However what is lacking is the initialization to "sane"
defaults in ALSA. 

In short: I am working on this, but I do not believe that the fix should be
exposing all HW controls, but instead just make the ALSA utils to find better
defaults for the redundant volume controls.
Comment 2 Lubomir Kundrak 2008-02-29 04:38:32 EST
I believe the hardware mixer is being still exposed in the Gnome volume control.
This is going to be fixed though :)
Comment 3 Lennart Poettering 2008-09-09 18:55:20 EDT
In PulseAudio 0.9.12 from rawhide we will now "extend" the hardware volume range in software. On one hand this means that we now can offer the same volume changing capabilities to all users regardless of what the hw supports, and otoh (which is more relevant here) we will always expose the hardware volume -- we won't hide it anymore under any circumstances. Which means that it is much more unlikely that a misconfigured alsa mixer will cause too silent audio, and much more likely that just using the pa mixer will fix the volume for you.

Also, in related news Jaroslav will upload alsa 1.0.18 to rawhide shortly which will initialize the alsa mixer by default more sensibly, so that PCM audio will always be hearable by default on the output device.

In summary this should mean that it is now much more likely that the audio device's volume will be correctly configured by default. And if it isn't pavucontrol will suffice to fix it. And if this doesn't work, it's a bug in alsa-util's default mixer setting database.

Note You need to log in before you can comment on or make changes to this bug.