Bug 386191 - For some reason, SE Linux keeps me from installing Darwin Streaming Server.
For some reason, SE Linux keeps me from installing Darwin Streaming Server.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 22:09 EST by Chuck Abraham
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 09:22:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
from SE Linux troubleshoot browser (2.74 KB, text/plain)
2007-11-15 22:09 EST, Chuck Abraham
no flags Details

  None (edit)
Description Chuck Abraham 2007-11-15 22:09:09 EST
Description of problem:
Can't seem to get Darwin Streaming Server to install.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Abraham 2007-11-15 22:09:09 EST
Created attachment 260711 [details]
from SE Linux troubleshoot browser
Comment 2 Daniel Walsh 2007-11-16 09:22:20 EST
Have you tried what setroubleshoot is suggesting?

I would suggest that you execute the following commands

# semodule fcontext -a -t textrel_shlib_t
'/usr/local/sbin/StreamingServerModules(/.*)?'
# restorecon -R -v /usr/local/sbin/StreamingServerModules

Then open a bug with Apple to build there shared libraries correctly.

You can attach this link to your bug report.

http://people.redhat.com/~drepper/selinux-mem.html

Since Apple does not use a standard location to install these files and they
don't use RPM, I can not automatically label these files.  So I am closing this
bug wontfix.  This is apples bug.

Note You need to log in before you can comment on or make changes to this bug.