This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 386321 - xlib.lock failed during x-plane install attempt
xlib.lock failed during x-plane install attempt
Status: CLOSED DUPLICATE of bug 390261
Product: Fedora
Classification: Fedora
Component: libxcb (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Patch, Reopened
Depends On:
Blocks: c->xlib.lock
  Show dependency treegraph
 
Reported: 2007-11-16 00:29 EST by Laurence Vanek
Modified: 2008-06-07 05:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 07:47:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 11390 None None None Never

  None (edit)
Description Laurence Vanek 2007-11-16 00:29:38 EST
Description of problem:

Attempt to reinstall x-plane via x-plane DVD installer.  No issue under Fedora 7
with exact same hardware.  Get the following under Fedora 8:

[lvanek@localhost ~]$ ./X-Plane-DVD-Install
X-Plane-DVD-Install: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted




Version-Release number of selected component (if applicable):


How reproducible:

every time


Steps to Reproduce:
1.  mount x-plane DVD
2. run installer from terminal window
3. enjoy error in terminal window
  
Actual results:

X-Plane-DVD-Install: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted

Expected results:

x-plane install

Additional info:
Comment 1 Matěj Cepl 2007-11-16 18:54:33 EST

*** This bug has been marked as a duplicate of 301691 ***
Comment 2 Laurence Vanek 2007-11-16 23:50:29 EST
sorry, but I do not believe this has anything to do with java.  The "sed fix"
workaround has been implemented with no joy
Comment 3 Michi 2007-11-17 10:08:29 EST
Hello,

I had The same bug. So I used the woraround. This worked probably and all my
java applications worked fine again.

Now, I wanted to update my BOINC-client form v5.8.2 to 5.10.2 but when I want to
start the boincmgr I get again this error. Workaournd dosn't work.
As far as I know BOINC is NOT written in Java, but in GKT1

Greetings,
Michi
Comment 4 Laurence Vanek 2007-11-18 12:56:09 EST
Apparently, they have decided the only problem they have is a java bug.  Im my
case there is no java on the install CD.

We dont seem to get the picture that this problem is larger than a java bug.  We
will as others try to install software.  I am waiting for the pressure to mount
from the user community.

bug marked as dup, life is good, "move along folks nothing to see here".

Comment 5 Matěj Cepl 2007-11-19 07:31:29 EST
I have already begun writing apologetic comment in the sense that everybody can
screw up (especially when dealing with hundreds bugs at once), but now I am not
that sure. Take a look at the upstream bug for bug 301691
(https://bugs.freedesktop.org/show_bug.cgi?id=11390#c3) -- it explains that the
problem is by far not with java itself, but it could be probably reproduced with
any program which statically compiles some X libraries and not others (well, it
can happen to any program which is not correctly statically linked).

So, reopening and it will need further investigation, whether the problem is on
our side, or with broken statical linking.
Comment 6 Laurence Vanek 2007-11-19 20:33:34 EST
I dont believe any of us now think its a Fedora/Redhat issue.  We are in hope
that perhaps Redhat  may have more influence with xorg that we (user community)
do.  From the xorg mail list it doesnt appear to be a priority with them.

The latest editions of Suse & Ubuntu also have this problem.  Somehow we need to
get xcb patched in a way that will make everyone happy (if thats possible)
otherwise 100's of commercial & open source programs will not install/run.
Comment 7 Petr Hrasky 2007-11-23 12:01:50 EST
I upgradedto f8 and x-plane 8.64 now fails with xllib.lock error too. It was
installed with f7 about a year ago.

[ph@hal9000 X-Plane 8.64]$ ./X-Plane-athlon-xp
X-Plane-athlon-xp: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted

The java workaround is useless here I think.
Comment 8 Markus Franke 2007-11-27 04:12:12 EST
Hi,

have the same problems with BOINC. I think the libxcb has to be patched with the
sloppy_lock patch from
http://www.linuxfromscratch.org/blfs/view/svn/x/libxcb.html. Would be nice to
get this patch integrated in the next libxcb packages.

Cheers,
Markus
Comment 9 Matěj Cepl 2007-11-27 04:25:54 EST
Patch added as an attachment 269541 [details] to the tracker bug 390261.
Comment 10 Matěj Cepl 2007-11-27 04:28:59 EST
(In reply to comment #8)
> Would be nice to get this patch integrated in the next libxcb packages.

I wouldn't expect this (originally OpenSuSE) patch will be used as a permanent
solution for Red Hat packages -- it explicitly mentions that it won't be
accepted as upstream patch, and we try to be as close to upstream as possible.
Comment 11 Laurence Vanek 2007-11-28 17:39:09 EST
A new version of libxcb (1.1) was released Nov 4 which permits the use 
of "sloppy_lock" environmental variable.

http://lists.freedesktop.org/archives/xcb/2007-November/003041.html

Will this version of libxcb make it into Fedora 8?  If not how long must one 
wait for a fix?

Comment 12 Edward Rudd 2007-12-11 11:42:31 EST
An update to Fedora 8 has been made recently (libxcb-1.0-4.fc8) that fixed the
*lock* issue with java (finally).  It may fix the lock issue with x-plane. (A
patch references in Freedesktop 11390 was applied)
Comment 13 Michi 2007-12-11 13:07:35 EST
Great, thanks! BOINC is working now again on my PC.
Comment 14 Laurence Vanek 2007-12-11 23:49:00 EST
I already got libxcb 1.1 from the dev repo & installed it.  set the
"sloppy_lock" environment variable and viola, x-plane installs and runs fine. 
Other than the spew of backtrace info that appears in the terminal window all
seems well.

Have not checked with version 1.0-4.fc8.

To repeat, this is not just a java problem.

Comment 15 Matěj Cepl 2008-01-10 07:47:01 EST
I am not saying that it is Java problem only.

*** This bug has been marked as a duplicate of 390261 ***

Note You need to log in before you can comment on or make changes to this bug.