Bug 386361 - Miro's main window does not render UTF8 characters properly
Miro's main window does not render UTF8 characters properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 01:04 EST by Michel Alexandre Salim
Modified: 2008-02-02 03:59 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 00:15:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for incorrect charset in template (598 bytes, patch)
2008-01-25 21:10 EST, Michel Alexandre Salim
no flags Details | Diff
New Miro spec (4.42 KB, text/plain)
2008-01-26 03:46 EST, Michel Alexandre Salim
no flags Details

  None (edit)
Description Michel Alexandre Salim 2007-11-16 01:04:42 EST
Description of problem:
When running Miro in the fr_FR.UTF-8 locale, the phrase "Downloading" is
Téléchargement en cours". This is rendered correctly on the left pane, but on
the main window heading it is rendered as Téléchargement en cours".

Version-Release number of selected component (if applicable):
Miro-0.9.9.9-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. LANG=fr_FR.UTF-8 miro
  
Actual results:
As described above

Expected results:
UTF-8 characters rendered correctly in all places

Additional info:
Comment 1 Alex Lancaster 2007-11-16 02:26:36 EST
I can reproduce this.  This is probably an upstream bug.  I'll check if Miro-1.0
(soon to be built, see bug #380811) fixes it.
Comment 2 Michel Alexandre Salim 2007-11-18 00:30:15 EST
Same with 1.0-1 in updates-testing -- probably upstream indeed, but I figured
I'll let the maintainer handle the communication.
Comment 3 Alex Lancaster 2007-11-18 02:26:42 EST
(In reply to comment #2)
> Same with 1.0-1 in updates-testing -- probably upstream indeed, but I figured
> I'll let the maintainer handle the communication.

Filed upstream:

http://bugzilla.pculture.org/show_bug.cgi?id=9269
Comment 4 Michel Alexandre Salim 2008-01-25 17:01:17 EST
Still the same with 1.1. Only one template uses iso-8859-1
(resources/template/download); changing that to utf-8 does not help.

I've tried looking at the code, and have so far narrowed it down to
portable/tabs.py, line 47: 'downloadtab': _('Downloading') which in fr.po is
translated to "Téléchargement en cours".

Alex, could you take this up with upstream? Also, if you don't mind, am
assigning the bug to you, since you've been doing the most recent updates
anyway, and I've never heard back from Thorsten.
Comment 5 Alex Lancaster 2008-01-25 19:44:43 EST
(In reply to comment #4)
> Still the same with 1.1. Only one template uses iso-8859-1
> (resources/template/download); changing that to utf-8 does not help.
> 
> I've tried looking at the code, and have so far narrowed it down to
> portable/tabs.py, line 47: 'downloadtab': _('Downloading') which in fr.po is
> translated to "Téléchargement en cours".
> 
> Alex, could you take this up with upstream? Also, if you don't mind, am
> assigning the bug to you, since you've been doing the most recent updates
> anyway, and I've never heard back from Thorsten.

I can try, I've filed several bugs with upstream but they almost never reply
(see the bug link for this issue in comment #3, which others have reported on
Ubuntu as well).  I'll try bugging (sic) them again on IRC.  There's a big
important issue with compiling Miro with xulrunner which will become default in
F-9 (see bug #393521) and no developer has made a single comment in the upstream
bug. :-(

Failing that we can locally patch.  If you make a patch for the RPM, I'll
happily add it to the package as I don't have a huge amount of time to do it
right now.

Comment 6 Michel Alexandre Salim 2008-01-25 21:10:56 EST
Created attachment 293033 [details]
Patch for incorrect charset in template

OK, turns out it was the broken template. Miro has a precompiled version that
it is using, thus my first attempt at changing the template (without
recompiling Miro) did not seem to produce the right effect.

Until I found this in portable/template.py:

if os.environ.has_key('DEMOCRACY_RECOMPILE_TEMPLATES'):

set the env variable and bingo! No more display issues.

Patch attached -- I'm doing a scratch build on Koji to test this out. Would you
like a comaintainer, by any chance?
Comment 7 Michel Alexandre Salim 2008-01-26 03:46:36 EST
Created attachment 293041 [details]
New Miro spec

Tested on my machine. Only change is the patched download template above, and
some sanitizing (package now has versioned Obsoletes: for Democracy and the
matching Provides:, some shebangs have been removed and COPYING has been
changed from DOS to UNIX end-of-lines.

rpmlint is now silent!
Comment 8 Fedora Update System 2008-01-26 06:01:55 EST
Miro-1.1-2.fc8 has been submitted as an update for Fedora 8
Comment 9 Alex Lancaster 2008-01-26 06:06:02 EST
(In reply to comment #7)
> Created an attachment (id=293041) [edit]
> New Miro spec
> 
> Tested on my machine. Only change is the patched download template above, and
> some sanitizing (package now has versioned Obsoletes: for Democracy and the
> matching Provides:, some shebangs have been removed and COPYING has been
> changed from DOS to UNIX end-of-lines.
> 
> rpmlint is now silent!

Thanks, applied, update pending:

https://admin.fedoraproject.org/updates/F8/pending/Miro-1.1-2.fc8

Let me know if it works OK and I'll push an F-7 update too.

Comment 10 Michel Alexandre Salim 2008-01-27 00:35:23 EST
Works fine. Could you build it for Rawhide as well?
Comment 11 Alex Lancaster 2008-01-27 01:20:08 EST
(In reply to comment #10)
> Works fine. Could you build it for Rawhide as well?

It's already rebuilt in rawhide.
Comment 12 Fedora Update System 2008-01-27 02:10:38 EST
Miro-1.1-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2008-1024
Comment 13 Michel Alexandre Salim 2008-01-27 18:49:06 EST
Ah. I guess it was not pushed yet when I upgraded to Rawhide yesterday. It's
there now, thanks.
Comment 14 Fedora Update System 2008-01-29 00:15:13 EST
Miro-1.1-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2008-02-02 03:59:35 EST
Miro-1.1-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.