Bug 386381 - Xorg intel driver won't switch to 1400x1050 mode
Xorg intel driver won't switch to 1400x1050 mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 02:15 EST by Mike Saavedra
Modified: 2008-02-12 16:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 16:09:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg log (83.69 KB, text/plain)
2007-11-16 02:15 EST, Mike Saavedra
no flags Details
It's my xorg.conf (1.53 KB, text/plain)
2007-11-30 03:22 EST, Riccardo Casazza
no flags Details
Xorg.0.log (99.63 KB, text/plain)
2007-11-30 03:23 EST, Riccardo Casazza
no flags Details

  None (edit)
Description Mike Saavedra 2007-11-16 02:15:59 EST
Description of problem:

I'm running Fedora 8 on an ASUS p5k-v motherboard (intel g33 chipset) with an
Acer AL2017A monitor (native resolution is 1400x1050). The xorg intel driver
sets the monitor to 1280x1024 mode. The screen size appears to be 1400x1050
though, so 120 pixels get chopped off the bottom, hiding the gnome panel.

I've tried messing around with creating my own modelines and using the
PreferredMode option, to no avail.


Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-devel-2.1.1-7.fc8
xorg-x11-server-Xorg-1.3.0.0-33.fc8


Steps to Reproduce:
1. Install Fedora 8 on the aforementioned hardware
2. Run X.
  
Actual results:
Monitor is set to 1280x1024 mode.

Expected results:
Monitor should be set to native 1400x1050 mode.

Additional info:

# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Module"
        Load  "glx"
        Load  "extmod"
        Load  "dri"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        ModelName    "Acer AL2017"
        HorizSync    30.0 - 82.0
        VertRefresh  56.0 - 76.0
        DisplaySize  408 306
        Option       "dpms"
        Modeline     "1400x1050@60" 121.75 1400 1488 1632 1864 1050 1053 1057
1089 -hsync +vsync
        Option       "PreferredMode" "1400x1050@60"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
        BusID "PCI:0:2:0"
        Option      "Monitor-VGA" "Monitor0"
        Option      "Monitor-VGA-1" "Monitor0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Depth     24
                Modes "1400x1050@60"
                Virtual 1600 1600
        EndSubSection
EndSection

Section "DRI"
        Mode         0666
EndSection
Comment 1 Mike Saavedra 2007-11-16 02:15:59 EST
Created attachment 260791 [details]
Xorg log
Comment 2 Mike Saavedra 2007-11-20 01:00:27 EST
After doing additional research, I've found a modeline that does work:

Modeline "1400x1050R"  101.00  1400 1448 1480 1560  1050 1053 1057 1080 +hsync
-vsync

This is a "reduced blanking" modeline generated by the following command:

cvt -r 1400 1050

Since the modeline created directly from the EDID information from my monitor
did not produce a properly functioning X, I suspect that the problem may just be
due to a quirky monitor, rather than a problem with the intel driver. Does xorg
or fedora maintain a "quirks list" of some sort for correcting problems such as
this? That may be the proper place to address this.

If you need any more help with this, I would be glad to offer any assistance.
Comment 3 Riccardo Casazza 2007-11-29 04:55:26 EST
Hi, I have exactly the same problem with a Samsung SyncMaster 203B and an Intel
Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02) with the
same resolution (1400x1050)
Comment 4 Matěj Cepl 2007-11-29 06:37:08 EST
(In reply to comment #3)
> Hi, I have exactly the same problem with a Samsung SyncMaster 203B and an Intel
> Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02) with the
> same resolution (1400x1050)

Did using the modeline from comment 2 helped?
Comment 5 Matěj Cepl 2007-11-29 06:37:47 EST
Mike, could we get your /var/log/Xorg.0.log attached to this bug as uncompressed
attachment, please?
Comment 6 Matěj Cepl 2007-11-29 06:38:46 EST
Also what happens, when you just remove (or rename) /etc/X11/xorg.conf and
restart Xorg?
Comment 7 Riccardo Casazza 2007-11-29 08:50:38 EST
(In reply to comment #4)
> (In reply to comment #3)
> > Hi, I have exactly the same problem with a Samsung SyncMaster 203B and an Intel
> > Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02) with the
> > same resolution (1400x1050)
> 
> Did using the modeline from comment 2 helped?

No: I've tried with cvt, cvt -r e gtf, no modelines were good
Comment 8 Riccardo Casazza 2007-11-29 08:52:36 EST
Moreover, 915resolution doesn't recognize my video card (while the xorg i810
driver does).
Here the output:

Intel 800/900 Series VBIOS Hack : version 0.5.3

Intel chipset detected.  However, 915resolution was unable to determine the
chipset type.
Chipset Id: 29c08086
Please report this problem to stomljen@yahoo.com
Comment 9 Riccardo Casazza 2007-11-29 08:55:33 EST
(In reply to comment #6)
> Also what happens, when you just remove (or rename) /etc/X11/xorg.conf and
> restart Xorg?

1280x1024 resolution is used: but, it is not a good resolution, i can see some
sort of bad interpolation is done and the image and the text are not at their best.
Comment 10 Matěj Cepl 2007-11-29 10:42:25 EST
Just one note, forget about 915resolution, it doesn't work anymore and it is not
supposed to work with intel driver.
Comment 11 Mike Saavedra 2007-11-29 12:19:17 EST
Matej, did you want my Xorg.0.log from the correctly working configuration I
have now, or the default one that I get if I delete my xorg.conf file? I
attached a previous non-functioning xorg.0.log on comment #1 .
Comment 12 Riccardo Casazza 2007-11-30 03:22:56 EST
Created attachment 273531 [details]
It's my xorg.conf

Here my xorg.conf...
Comment 13 Riccardo Casazza 2007-11-30 03:23:59 EST
Created attachment 273541 [details]
Xorg.0.log

...and Xorg.0.log
Comment 14 Mike Saavedra 2007-11-30 12:14:27 EST
Riccardo, try adding the "PreferredMode" option to the "Monitor" section of your
xorg.conf. The intel driver is designed for automatic configuration and will not
actually use the modeline you create yourself unless you specify that your
modeline is to be preferred.

See my xorg.conf in the bug summary for an example of how PreferredMode works. I
don't believe it is actually documented anywhere.

I suspect that this, combined with the reduced blanking mode listed above, will
fix your problem. I have read reports that the Syncmaster 203B is a quirky
monitor like mine.
Comment 15 Riccardo Casazza 2007-11-30 12:23:39 EST
It didn't fix the problem.
The result is as usual: it is like if it was 1400x1100 or something and not
1400x1050 and there is a part of the screen lower than the monitor. Even
clicking on 'auto' on the monitor doesn't solve the problem.
Comment 16 Adam Jackson 2008-02-12 16:09:54 EST
I'm almost certain this is resolved as of xorg-x11-server-1.3.0.0-36.fc8.  We
had a bug in the EDID parser that would generate modelines with the sync
polarities the wrong way around, which appears to be the only difference between
the modeline generated by hand in comment #2 and the modeline generated by the
server in attachment #260791 [details].  In -36 we updated the EDID parser and quirks
table from git master xserver, so this should be resolved now.

Please test with a current F8-updates X server, and reopen if this is still an
issue for you.

Note You need to log in before you can comment on or make changes to this bug.