Bug 386421 - Vortex86-SoC stuck after "Write protecting the kernel read-only data"
Vortex86-SoC stuck after "Write protecting the kernel read-only data"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 02:46 EST by Warren Togami
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 15:06:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-11-16 02:46:33 EST
http://www.disklessworkstations.com/cgi-bin/web/200110.html
http://www.disklessworkstations.com/cgi-bin/web/info/ltsp_t1000.html
Popular thin client with strange CPU.  Many people are using this with Ubuntu.

http://www.dmp.com.tw/
"Vortex86 is a SoC which integrate a 200MHz x86 compatible processor,
NorthBridge, advanced hardware GUI engine and Super-South bridge."

echo "59.120.27.69    www.vortex86.com" >> /etc/hosts
(sigh... their DNS is down)
http://www.vortex86.com/index2.html
Platform Specifications

Tested with:
kernel-2.6.23.1-49.fc8.i586
kernel-2.6.23.1-56.fc8.i386 (built manually)

Freeing unused kernel memory: 280k
Write protecting the kernel read-only data: 844k

At this point it gets stuck.  I then took kernel/F-8, make prep, copied
config-i586 to config-i386 and made changes so it could build.  Had to disable
SSB, B43 and B44 so the build would complete.  The i386 kernel based on -56
unfortunately has the same problem.

I tried all of these options, but they made no difference.
pci=nomsi,nommconf nohz=off highres=off nolapic_timer noapictimer nolapic noapic
acpi=off

I tried "initcall_debug".  Nothing displays after "Write protecting the kernel"
before it gets stuck.

This box has no serial port.
Comment 2 Warren Togami 2007-11-16 15:06:59 EST
NOTABUG, it turns out that glibc.i686 was installed in the chroot.

Note You need to log in before you can comment on or make changes to this bug.