Bug 38643 - Installer fatal error on upgrade when fstab includes multi disk device
Summary: Installer fatal error on upgrade when fstab includes multi disk device
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-01 20:30 UTC by Richard Blocker
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 17:47:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump from anaconda saved during upgrade (11.57 KB, text/plain)
2001-05-01 20:31 UTC, Richard Blocker
no flags Details
raidtab and fstab from upgraded box (1.36 KB, text/plain)
2001-05-01 21:40 UTC, Richard Blocker
no flags Details

Description Richard Blocker 2001-05-01 20:30:01 UTC
The installer hangs during an upgrade from RH6.1 to RH7.1 when the fstab
includes /dev/md0.  Workaround, comment out the /dev/md0 line before
upgrade.

Comment 1 Richard Blocker 2001-05-01 20:31:06 UTC
Created attachment 16986 [details]
Dump from anaconda saved during upgrade

Comment 2 Brent Fox 2001-05-01 21:28:30 UTC
Can you attach your /etc/fstab and /etc/raidtab files?

Comment 3 Richard Blocker 2001-05-01 21:40:51 UTC
Created attachment 16989 [details]
raidtab and fstab from upgraded box

Comment 4 Richard Blocker 2001-05-01 21:46:50 UTC
The raidtab and fstab are not exactly the same as when I did the upgrade, but 
very nearly so.  The the workaround actually involved commenting out the /dev/md0 
line in the fstab, temporarily removing the raidtab, and disconnecting the RAID 
disks from their respective controllers.  Since I am booting from a SCSI disk, 
this worked for me.


Comment 5 Brent Fox 2001-05-01 22:21:54 UTC
Where did it hang?  Raid upgrades work on our machines here.

Comment 6 Richard Blocker 2001-05-03 13:59:30 UTC
It appears to hang during the mount of the file systems.  I cannot remember 

exactly when the error message came, but it was after I had chosen the upgrade 

option and before any files were actually copied to the system disk.  There was 

enough information in the error window that popped up to give me the idea of 

commenting out the /dev/md0 line in fstab -- something about failing temporary 

mount of multi-disk device.  The message also asked me to save the anaconda dump 

and submit the bug report.  I assumed it would have all the information about 

what was going on at the time. Could the problem be related to the fact that this 

is an IDE RAID with a SCSI boot disk?  This seems to me to be a fairly unusual 

setup.



Comment 7 Brent Fox 2001-05-03 16:19:27 UTC
Yes, it could have something to do with IDE RAID with a SCSI boot disk.  Does
the behavior change if you boot the installer by saying 'linux ide=nodma'?

Comment 8 Richard Blocker 2001-05-03 17:47:47 UTC
That I don't know.  Once I got the upgrade to happen I was happy.  If you want
to experiment with this, it's a Promise Ultra 66 PCI card in addition to the
Tyan S2390A onboard IDE contollers with 4, 75GB IBM DeskStar 75 GXP disks
connected one per IDE channel (80 wire UltraATA cables).  The SCSI is a BusLogic
BT-946C controller with one, 18GB IBM DNES-318350W, and an external Toshiba
cdrom.

Comment 9 Brent Fox 2001-05-04 14:22:50 UTC
Ok.  I'm glad you got the upgrade to work.  I'm pretty sure that this was caused
by the some devices having troubles with dma transfers.  We've seen a few of
those.  Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.