Bug 38645 - Anaconda fails to run after loading symbios drivers
Summary: Anaconda fails to run after loading symbios drivers
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Inti   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-01 20:53 UTC by Mark Brotherton
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 21:43:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci -vb (3.04 KB, text/plain)
2001-05-01 20:54 UTC, Mark Brotherton
no flags Details
Output of lspci -vn (2.26 KB, text/plain)
2001-05-01 20:54 UTC, Mark Brotherton
no flags Details

Description Mark Brotherton 2001-05-01 20:53:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0smp i686)


Attempted to run RH7.1 installer from CDROM using following flags:
linux expert text noprobe nousb (and various permutations therein).

After finding and loading the symbios driver (ncr version), it hangs on the
load of ext3.o

Running same installer with additional noapic flag creates a failed load of
the glibc.so.6, again, dies nicely, unmounts drives, and asks to be
rebooted.


Reproducible: Always
Steps to Reproduce:
1. Run 7.1 installer from cdrom
2. Manually select the SCSI driver
3. Watch it fail over and over again
	

Actual Results:  On an Alt-F3 screen, it shows the various driver loads,
and fails on ext3.o

On the Alt-F1 screen, anaconda fails, dismounts the drives nicely, and
tells me its ok to reboot.

Expected Results:  The installer should run...

Comment 1 Mark Brotherton 2001-05-01 20:54:27 UTC
Created attachment 16987 [details]
Output of lspci -vb

Comment 2 Mark Brotherton 2001-05-01 20:54:55 UTC
Created attachment 16988 [details]
Output of lspci -vn

Comment 3 Mark Brotherton 2001-05-01 21:20:20 UTC
More detail:

Actual verbatim output begins with:

Running anaconda...install exited abnormally -- received signal 11
Sending termination signal...done
Sending kill signal...done
Unmounting...
<snip>
You may now reboot your machine

Comment 4 Brent Fox 2001-05-01 21:33:59 UTC
Looks like a kernel problem...changing component

Comment 5 Arjan van de Ven 2001-05-01 21:45:59 UTC
Is this a IDE cdrom driver ?
If so, please try using the "ide=nodma" option in the place where you
did "noapic" before. If that doesn't fix it, it's an anaconda segfault

Comment 6 Mark Brotherton 2001-05-02 06:22:58 UTC
That ('ide=nodma') was it. Thanks much!

Strikes me as kinda odd that support had me report it as a bug, tho...

Shouldn't this be something that belongs in the knowledgebase (e.g., 'Installing
to SCSI Hard-Drives with IDE CD-Rom controllers').

Just wondering.

So do I close the bug or do you?

Comment 7 Arjan van de Ven 2001-05-02 08:54:42 UTC
Support has a kb article about IDE cdrom drives. Maybe the relation to SCSI
messed the "ah it must be that" up.

Can you do me a favour and do a 
cat /proc/ide/hda/model
(replace "hda" with the real device of your cdrom drive) ?
This way, we can mark your cdromdrive as non-DMA capable and fix it for future
versions. Thanks.

Comment 8 Mark Brotherton 2001-05-02 21:43:19 UTC
cat /proc/ide/hda/model

shows: HITACHI CDR-8435

Comment 9 Arjan van de Ven 2001-05-02 21:51:09 UTC
Thank you for the information. I've added it to the list of cdrom drives
the kernel will not use DMA on. 

Two days ago I added  "HITACHI CDR-8335"  to the list.. looks like they made
a series of them ;)


Note You need to log in before you can comment on or make changes to this bug.