Bug 38650 - installer fails when reading basesystem package
installer fails when reading basesystem package
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-01 17:11 EDT by Need Real Name
Modified: 2007-03-26 23:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 16:02:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-01 17:11:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686; Nav)


Installer fails in text mode install of custom or GNOME system on Dell 8100
system from CDROM.
All anaconda updates were applied. 
Source CDROM was manufactured by RedHat.


Reproducible: Always
Steps to Reproduce:
1.Boot from floppy (boot-20000407.img), boot: linux updates text
2. Insert updates floppy (update-disk-20000419.img)
3. Select custom system
4 Mount / on /dev/hda3 (24GB) Swap 512 MB
5. Accept defaults on config options
6. Installer fails reading package information for basesystem
	

Actual Results:  Python crash dump	
Exception Occurred
Traceback (Innermost last):
File "/usr/bin/anaconda", Line 342 in ? 
	intf.run(todo, test=test1)
File "/usr/lib/anaconda/text.py" Line 1165 in run 
	rc = apply(step[1](), step[2])
File "/usr/lib/anaconda/textw/packages.py", Line 11 in __call__ 
	todo.getComList()
File "/tmp/updates/todo.py" Line 469 getCompsList 
	self.comps = self.method.readComps(self.hdList)
File "/usr/lib/anaconda/image.py" Line 8 in readComps 
	return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
File "/usr/lib/anaconda/comps.py" line 326 in __init__
	self.readCompsFile(file, self.packages)
File "/usr/lib/anaconda/comps.py" line 299 in readCompsFIle
	comp.addPackage(packages[1])
File "/usr/lib/anaconda/comps.py" line 46 in __getitem__
	return self.packages[item]
Keyerror: basesystem

Expected Results:  An installed and correctly functioning Linux
installation.
Comment 1 Brent Fox 2001-05-01 17:32:47 EDT
Does it fail at the same point every time?
Comment 2 Need Real Name 2001-05-02 09:08:06 EDT
Yes, it crashes at the same spot every time, i.e. same traceback messages.
Comment 3 Brent Fox 2001-05-02 15:04:25 EDT
These kind of problems are almost always a bad cd.  Has this cd ever worked on
other machines before?
Comment 4 Need Real Name 2001-05-02 15:16:57 EDT
The source CDROM is a RedHat "factory" CD right out the RH 6.2 Deluxe box and
has been used on 2 eMachine 500's, however, this is the first time I've tried it
on a Dell Dimension 8100. I also downloaded the iso 2 nights ago and extracted
it to a FAT32 partition and tried installing from a hard drive partition. Same
problem, however, I'm not sure if it gave the same traceback. I burned the iso
onto a CD, and had the same problems. I tried a Penguin Power RedHat 6.2 CD I
had laying around with the same problem.
Comment 5 Brent Fox 2001-05-02 15:42:40 EDT
Hmm...I don't know what the problem is.  I'm curious if you would see the same
error on Red Hat Linux 7.1.  Do you have a way to download it?
Comment 6 Need Real Name 2001-05-02 15:53:24 EDT
I can try the 7.1 installation however, I would prefer to stay away from the 2.4
kernel until it's been "in the field" a little bit longer. As an addtional note,
I was able to do an FTP install of the basesystem RH 7.0.
Comment 7 Brent Fox 2001-05-02 16:02:50 EDT
I understand.  Well, I don't really have an answer for you in regards to 6.2.
But at least 7.0 works for you, which makes me think that the problem is also
fixed in 7.1.  I'm resolving the bug as "Current Release", meaning that the
problem has been fixed in newer releases.  If and when you do try 7.1, please
reopen this bug if the problem reappears.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.