Bug 38654 - [dma] installer hangs on /sbin/loader
Summary: [dma] installer hangs on /sbin/loader
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-01 22:32 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 12:10:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-05-01 22:32:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


installer locks up on blue screen immediately after /sbin/loader.

in expert mode, installer prompts for: driver disk (no), language 
(english), keyboard (us), media (local cdrom)... then CD rom spins up, 
spins down, and system is locked up with blue screen.

Machine has a pentum III/500mhz, 128mb single chip sdram, tyan 
motherboard, ATI Rage 3d video, IDE CDROM, 10gb IDE hard drive, and 
nothing else.  I even pulled the 3com 3c5xx pci card, and it still locks 
up.

SuSE 7.1 is currently on the system (its installer ran flawlessly) but I 
was rying to replace it with redhat (I wanted the 2.4.2 kernel for 
iptables, bind 9, bindconf and apacheconf modules).

Reproducible: Always
Steps to Reproduce:
1.insert install cd rom
2.power up.
3.hit enter to continue
viola - locked up.
	

Actual Results:  machine hangs

Expected Results:  installer runs

see above

Comment 1 Need Real Name 2001-05-01 22:43:04 UTC
after a while, it finally said:

failed to read /modules/module-info

install exited abnormally sending termination signal yada yada yada you may now 
safely reboot yuor system

Comment 2 Bob Colbert 2001-05-02 01:12:34 UTC
It doesnt work for me either.  Same exact symptoms as this post.  I have a 
Pentium 4, 1.4 GHz and an Intel 850 board.

Comment 3 Bob Colbert 2001-05-02 01:23:54 UTC
Saw something after checking all posts having anything to do with installing 
RedHat 7.1  It seems that it is something with a BIOS limitation and 2.88MB 
images from the CDROM.  Apparently if you make a floppy boot disk from the 
CD /images then it will work.  I havent tried it yet..but I will in a few 
minutes.

Bob


Comment 4 Bob Colbert 2001-05-02 02:09:21 UTC
Nope, making a boot disk as suggested in another bug report did not work 
either.  It hangs at /sbin/loader either with default or text install.  I also 
updated to my latest Intel 850 BIOS to P12 thinking that the 2.88 mb image file 
problem would be fixed, but nada.  Still same underlying problem as this 
original post.


Comment 5 Brent Fox 2001-05-02 14:22:48 UTC
Can either of you look on VC3 and VC4 and see if there are any error messages?

Comment 6 Bob Colbert 2001-05-02 19:33:37 UTC
No.  The computer is completely locked up. No console switching, ctrl-alt-del, 
or anything.  Had to hold my power button in for 5-7 seconds to force it off.

Comment 7 Brent Fox 2001-05-02 19:55:42 UTC
What if you boot with 'linux ide=nodma'?

Comment 8 Bob Colbert 2001-05-04 00:37:38 UTC
the linux ide=nodma worked for me.  Better post that solution more prominently 
somewhere.  Im sure we arent the only two that experienced that problem.

Thanks for the help though..everything else installed without a glitch.

Bob

Comment 9 Brent Fox 2001-05-09 16:23:05 UTC
Yes, this is a known issue.  It will help us a lot if you can send the output of
/proc/ide/hd(foo)/model so we can see the model name of the cdrom.  Changing
component to the kernel.

Comment 10 Bob Colbert 2001-06-12 12:10:27 UTC
output from /proc/ide/hdc/model

CD-R/RW RW7063A

I dont remember what brand it was that I bought but I dont think it was 
a 'name' brand.

Bob


Note You need to log in before you can comment on or make changes to this bug.