Bug 38668 - package won't install (probably wrong deps, provides)
Summary: package won't install (probably wrong deps, provides)
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: ruby (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2001-05-01 23:40 UTC by Dimitri Papadopoulos
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-01 23:41:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Dimitri Papadopoulos 2001-05-01 23:40:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

$ rpm -i ruby-1.6.2-4.i386.rpm
error: failed dependencies:
        libruby = 1.6.2 is needed by ruby-1.6.2-4
        libruby.so.1.6   is needed by ruby-1.6.2-4
$ rpm -i --nodeps ruby-1.6.2-4.i386.rpm
$ rpm -i ruby-tcltk-1.6.2-4.i386.rpm
error: failed dependencies:
        libruby = 1.6.2 is needed by ruby-tcltk-1.6.2-4
        libruby.so.1.6   is needed by ruby-tcltk-1.6.2-4

Reproducible: Always
Steps to Reproduce:
This is not really needed, is it?

Expected Results:  Package should install without complaining.

Comment 1 Tim Powers 2001-05-02 00:32:07 UTC
You don't have the libruby package installed. Install that first and the others
should install as well. The following error:

 libruby = 1.6.2 is needed by ruby-1.6.2-4

Means that it needs at least the libruby-1.6.2 package installed to fulfill


Comment 2 Dimitri Papadopoulos 2001-05-02 05:44:28 UTC
My error, sorry. But why do you have a separate libruby? Why is this package
different from
python for example? And why nit a ruby-lib package? sorry for all these


Comment 3 Dimitri Papadopoulos 2001-05-02 05:48:32 UTC
Yes, really sorry for being so talkative. I did find a pythonlib package.

The ruby package should be called rubylib as well to be consistent,
shouldn't it? It's also easier to find when installing.

Note You need to log in before you can comment on or make changes to this bug.