Bug 3868 - /dev/sg? driver trouble
/dev/sg? driver trouble
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-02 09:32 EDT by Fabian Kroenner
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-28 01:36:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Kroenner 1999-07-02 09:32:12 EDT
Description:
------------

User compiled programs that access the /dev/sg? interface
(like cdrecord) generate scsi-command errors.
This is due to a bug in the package glibc-devel that comes
with Red Hat Linux 6.0. The directory /usr/include/scsi
should be a symbolic link to /usr/src/linux/include/scsi to
warrant consistency of the kernel's sg-driver-interface
version with the headers used by the compiler.


Affected Package:
-----------------

glibc-devel


Related Package:
----------------

kernel-headers


Solution:
---------

(Re)move the directory /usr/include/scsi and create a
symbolic link from
/usr/include/scsi > /usr/src/linux/include/scsi

like this:

# cd /usr/include
# mv scsi scsi.orig
# ln -s ../../src/linux/include/scsi scsi

Now recompile the affected program.
Comment 1 Cristian Gafton 1999-07-28 01:36:59 EDT
The glibc headers provide a cross-system generic scsi interface for
use by high-level programs. Applications like cdrecord should look
instead directly into the kernel headers, since they need hard data
that is highly architecture and OS dependent.

Note You need to log in before you can comment on or make changes to this bug.