Bug 386961 - During upgrade from F7 to F8, anaconda shows negative 'Free space' in lvm volume
During upgrade from F7 to F8, anaconda shows negative 'Free space' in lvm volume
Status: CLOSED DUPLICATE of bug 437443
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 10:02 EST by Steve
Modified: 2008-06-03 14:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 14:45:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output generated by the 'lvmdump' command on F7. (16.24 KB, application/octet-stream)
2007-11-16 10:02 EST, Steve
no flags Details
output of 'lvm pvdisplay', 'lvm vgdisplay' and 'lvm lvdisplay' from the install environment. (4.68 KB, application/x-gzip)
2007-11-16 10:04 EST, Steve
no flags Details
Screen shots (548.54 KB, application/x-gzip)
2007-11-16 10:04 EST, Steve
no flags Details

  None (edit)
Description Steve 2007-11-16 10:02:42 EST
> Description of problem:
I am trying to upgrade my laptop from F7 to F8 (F7 itself was upgraded to from a
FC6 fresh install). At the partitioning stage, when I select the existing lvm vg
and choose to edit it (so that I may select the mount points and make sure the
partitions would not be formatted) I see the following information displayed:

Used Space: 75296.00 MB
Free Space: -32.00 MB
Total Space: 75264.00 MB

Further when I try to specify the mount point for any of the logical volumes,
and choose to leave the volume unformatted, I get an error to the effect that
the selected space for the LV is greater that the available free space.

> Version-Release number of selected component (if applicable):
F8 anaconda

> How reproducible:
Consistently, on my laptop.

Steps to Reproduce:
1. Start the installation.
2. Get to the partitioning stage and choose to 'Create custom layout' (for an
upgrade).
3. Select the existing (F7 based) Volume group and choose 'Edit'.
4. Notice that 'Used Space' is greater than 'Total Space' and 'Free Space' is
negative.
  
Actual results:
'Used Space' is greater than 'Total Space' and 'Free Space' is negative, so
cannot continue with a non-destructive upgrade.

Expected results:
Anaconda should recognize current partitioning scheme correctly and allow the
user to simply specific the mount points, select to leave the partitions
unformatted and continue with the installation.
 

Additional info:
I am attaching the following files:
lvmdump-dhcp6-178.pnq.redhat.com-20071116130009.tgz ....... The output generated
by the 'lvmdump' command on F7.
lvminfo.tar.gz ........ A tarball containing the output of 'lvm pvdisplay', 'lvm
vgdisplay' and 'lvm lvdisplay' from the install time command line environment.
screenshots.tar.gz ...... Screen shots (actually, camera shots) of the
installation sequence (The 'alt+print screen' does not seem to capture the
screenshots at this stage)
Comment 1 Steve 2007-11-16 10:02:42 EST
Created attachment 261301 [details]
The output generated by the 'lvmdump' command on F7.
Comment 2 Steve 2007-11-16 10:04:04 EST
Created attachment 261321 [details]
output of 'lvm pvdisplay', 'lvm vgdisplay' and 'lvm lvdisplay' from the install environment.
Comment 3 Steve 2007-11-16 10:04:32 EST
Created attachment 261331 [details]
Screen shots
Comment 4 Steve 2007-11-16 10:08:55 EST
Some additional info that may/may not be relevant:

a. This is a PXE booted, httpd based install over LAN

b. I remember having resized my LVs at least once (maybe more) after moving from
FC6 to F7.

c. I have non standard LV labels and two non standard filesystem mount points
('/NotBackedUp' and '/space')
Comment 5 Wojciech Pilorz 2008-01-07 04:10:34 EST
I had the same problem with anaconda not properly calculating space on LVM when
installing Fedora8 from DVD (using GUI installer, new install)
with preexisting lvm logical volumes.
I had 3 volumes groups, and anaconda did show -96.00MB.
I have screenshots available, I can attach them if they are needed

PS1. The screenshots.tgz file attached is doubly compressed, run
   zcat screenshots.tgz | tar xfz -
to extract files.
PS2. I would believe that this bug is not present in CentOS 5.1 installer.
  The bug was definitely present in FC6
Comment 6 Andy Lindeberg 2008-06-03 14:45:39 EDT

*** This bug has been marked as a duplicate of 437443 ***

Note You need to log in before you can comment on or make changes to this bug.