Bug 387 - lprm cannot cancel printjobs remotely
lprm cannot cancel printjobs remotely
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-11 08:16 EST by klaus
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-11 11:59:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description klaus 1998-12-11 08:16:43 EST
When I try to cancel a printjob on a remote printserver
running lpd from package lpr-0.33 I get a message
"permission denied". The host from which I sent the
printjob is identical to the one I sent the lprm from.
No matter if I try it as user or root.
I can login as root to the printserver and cancel the job
from there -- or I can edit the printjobs control file and
change the "H"-entry from "hostname" to "hostname.my.domain"
and then cancel the job from the sending host.
Comment 1 Jay Turner 1998-12-11 09:51:59 EST
Is the print server in the same domain that the sending host is in, or
a different one?  If the printer server is in a different domain, then
there could be some confusion with name resolution, hence the reason
that it works when you edit the control file entry.
Comment 2 rmehenda 1999-12-15 18:19:59 EST
I had the same problem with RH6.0 original and 0.46-1 lpr. Remote print jobs
could not be canceled when sent from another RH6.0, however changing the "H"
entry as suggested by klaus works. I could cancel remote print jobs sent from
another host running Debian 2.0. The only difference was the cf file didn't have
the FQDN for the client host on the "H" line! Replacing the 0.46-1 lpr binary
with the one from the Debian system fixed the problem. Hence, bug in hostname
lookup?? This would be the first time for me trying to compare two sources!
Anybody?
Comment 3 Zdenek Drlik 2000-01-05 03:06:59 EST
I have the same problem with FQDN too on RedHat 6.0. When I print to printer
server from RH 6.1 or from HPUX 10.20, it prints fine. But when I want to remove
job from queue, I get "permission denied". In cf file there is on "H" line the
pc name only (e.g. pc55). When I write FQDN instead of this (e.g. pc55.net1.kb),
the job should be removed without problems. Is there any way to tell the lpd to
store the FQDN instead the name of the pc only?
Comment 4 Zdenek Drlik 2000-01-06 05:41:59 EST
I solved this problem. On all computers which prints to my print server by
Linuxconf I set the computer name to FQDN and reboot the computer and problem is
solved. Before this change, the cf file was named with FQDN, df was only
computer name and H-line in cf was comp name too (e.g. printing prom
pc55.net1.kb: cfA024pc55.net1.kb, dfpc55 and in cf: Hpc55 - and this causes
permission denied error). After changing computer name of pc55 to pc55.net1.kb
all entries and files are pc55.net1.kb and removing jobs work fine.

Note You need to log in before you can comment on or make changes to this bug.