Bug 387061 - Lost "focus follows mouse" functionality
Summary: Lost "focus follows mouse" functionality
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz-fusion   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Adel Gadllah
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-16 15:45 UTC by J French
Modified: 2018-04-11 12:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 17:54:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description J French 2007-11-16 15:45:46 UTC
Description of problem:
Lost the ability to change focus to windows by moving mouse over them when
running compiz-fusion

Version-Release number of selected component (if applicable):
compiz-0.6.2-3.fc8

How reproducible:
Every time

Steps to Reproduce:
1. System > Preferences > Look and Feel > Windows > check "Select windows when
the mouse moves over them"
2. Start compiz with "compiz-manager"
  
Actual results:
Window focus doesn't follow mouse

Expected results:
Focus should follow mouse

Comment 1 Adel Gadllah 2007-11-17 10:00:33 UTC
Are you using kde ? Does it work if you start compiz with "dektop-effects" ?

Comment 2 J French 2007-11-17 15:27:56 UTC
I'm using Gnome and if I start compiz using any method other than
compiz-manager, CCSM has no effect.

See: https://bugzilla.redhat.com/show_bug.cgi?id=376551

Comment 3 Matěj Cepl 2007-12-12 17:54:22 UTC
Am I correct in understanding that this is actually duplicate of bug 376551?

*** This bug has been marked as a duplicate of 376551 ***

Comment 4 Mohd Izhar Firdaus Ismail 2007-12-12 18:09:27 UTC
(In reply to comment #3)
> Am I correct in understanding that this is actually duplicate of bug 376551?
> 
> *** This bug has been marked as a duplicate of 376551 ***

I believe its not

the reporter seems like he wants the metacity feature of focusing a window when
the mouse is hovered on it.

(In reply to comment #0)
> Description of problem:
> Lost the ability to change focus to windows by moving mouse over them when
> running compiz-fusion
> 
> Version-Release number of selected component (if applicable):
> compiz-0.6.2-3.fc8
> 
> How reproducible:
> Every time
> 
> Steps to Reproduce:
> 1. System > Preferences > Look and Feel > Windows > check "Select windows when
> the mouse moves over them"

System > Preferences > Look and Feel > Windows is a preferences dialog for
metacity, which does not applies to compiz, if you want this functionality,
change it at compiz configuration itself. If ure using Compiz with ccp (the one
launched using compiz-manager), set it at this menu inside CCSM. General compiz
options > Focus & Raise Behaviour . Disable "Click to Focus" and enable
"Auto-Raise". If you are using Compiz with Gconf (the default ran from
desktop-effects), find the GConf key for that.

IMO, this is NOTABUG. 


Comment 5 J French 2007-12-12 19:00:27 UTC
Thank you, you are correct. I was unaware of the option.

Comment 6 Randy Yates 2008-03-11 20:27:04 UTC
I found on a fresh install of a gnome-based fedora 8 system, and using the
kmod-nvidia driver (if it makes a difference, but fyi) that installing
gnome-compiz-manager solved this problem. Apparently gnome-compiz-manager reads
your metacity configuration (such as System/Preferences/Look and Feel/Windows)
and configures the compiz window manager accordingly. 


Note You need to log in before you can comment on or make changes to this bug.