Bug 387071 - Java Applications don't work
Java Applications don't work
Status: CLOSED DUPLICATE of bug 301691
Product: Fedora
Classification: Fedora
Component: java-1.5.0-gcj (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 11:00 EST by markm
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 11:39:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description markm 2007-11-16 11:00:01 EST
Description of problem:

Trying to install ZendStudio get error: 

[root@Mareg ~]# sh /home/marek/Desktop/ZendStudioNeon-BETA.bin 
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted
[root@Mareg ~]# 

Version-Release number of selected component (if applicable):

java in general

How reproducible:

everytime

Steps to Reproduce:
1. Download Zend Studio or Zend Studio for Eclipse
2. Try to install it
  
Actual results:

Installation is aborted

Expected results:

Installation is not aborted

Additional info:

My big question is - why do you introduce Java version which doesn't work? I
don't get it - I thought Fedora 8 is going to be more user friendly and better
prepared to be a desktop linux, but it was just my wishful thinking. I use
Fedora as my workstation at work, believe me or not, I don't want to spend weeks
on looking for resolution how to install application, which is needed for my
work. If "open" java is not ready to replace sun's java, why are you forcing it? 
the same is with iwl3945 driver - it doesn't work, but you dropped ipw3945 which
actually works and Fedora provides only iwl3945 which doesn't work. Lovely.
Comment 1 Thomas Fitzsimmons 2007-11-16 11:39:03 EST
(In reply to comment #0)

> [root@Mareg ~]# sh /home/marek/Desktop/ZendStudioNeon-BETA.bin 
> Preparing to install...
> Extracting the JRE from the installer archive...
> Unpacking the JRE...

[...]

> My big question is - why do you introduce Java version which doesn't work?

[...]

The installer is using a JRE that it bundles, not the system JRE.  The bundled
JRE has a known bug that is exposed by libxcb's stricter lock checking.  We
fixed this bug in the system JRE, IcedTea, during the Fedora 8 development
cycle, so if the installer were using the system JRE as you assume, you wouldn't
be hitting this bug.

It would be helpful if you attempted to run the installer on IcedTea, and report
the results.  Otherwise, try Adam Jackson's workaround in bug 301691, comment 19.

*** This bug has been marked as a duplicate of 301691 ***
Comment 2 markm 2007-11-16 12:07:54 EST
thanks, will try the workaround.

but don't get me wrong - from user's point of view it looks like "new Fedora =
new problems" :)
Comment 3 markm 2007-11-16 12:13:31 EST
it didn't help

Note You need to log in before you can comment on or make changes to this bug.