Bug 387191 - logs flooded with EDNS messages.
logs flooded with EDNS messages.
Status: CLOSED DUPLICATE of bug 275091
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 11:46 EST by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 05:02:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2007-11-16 11:46:33 EST
so far this morning, I have 1792 messages like the following in my logs..

ov 16 10:59:36 firewall named[1642]: too many timeouts resolving
'clockmail.net/A' (in 'clockmail.NET'?): disabling EDNS
Nov 16 10:59:36 firewall named[1642]: too many timeouts resolving
'clockmail.net/MX' (in 'clockmail.NET'?): disabling EDNS
Nov 16 10:59:39 firewall named[1642]: too many timeouts resolving
'clockmail.net/A' (in 'clockmail.NET'?): disabling EDNS
Nov 16 10:59:39 firewall named[1642]: too many timeouts resolving
'clockmail.net/MX' (in 'clockmail.NET'?): disabling EDNS
Nov 16 10:59:39 firewall named[1642]: too many timeouts resolving
'rainwatch.cn/NS' (in 'rainwatch.cn'?): disabling EDNS
Nov 16 10:59:43 firewall named[1642]: too many timeouts resolving
'clockmail.net/A' (in 'clockmail.NET'?): disabling EDNS
Nov 16 10:59:43 firewall named[1642]: too many timeouts resolving
'clockmail.net/MX' (in 'clockmail.NET'?): disabling EDNS
Nov 16 10:59:47 firewall named[1642]: too many timeouts resolving
'clockmail.net/A' (in 'clockmail.NET'?): disabling EDNS
Nov 16 10:59:47 firewall named[1642]: too many timeouts resolving
'clockmail.net/MX' (in 'clockmail.NET'?): disabling EDNS
Nov 16 11:15:20 firewall named[1642]: too many timeouts resolving
'wirejoin.cn/NS' (in 'wirejoin.cn'?): disabling EDNS
Nov 16 11:30:55 firewall named[1642]: too many timeouts resolving
'ns2.affa-soft.com/A' (in 'affa-soft.com'?): disabling EDNS
Nov 16 11:30:55 firewall named[1642]: too many timeouts resolving
'ns1.affa-soft.com/A' (in 'affa-soft.com'?): disabling EDNS


How do I fix / disable this ?

oddly, all the hostnames it complains about resolve just fine when run with
'host' from the command line.
Comment 1 Adam Tkac 2007-11-19 05:02:54 EST
Specify "edns no" option in options statement. But real problem is usually
broken firewall or router which blocks big ( > 512b) packets. I recommend you
try edns-udp-size 512; option and if your log also has many messages
"..disabling EDNS" complete disable it.
Comment 2 Adam Tkac 2007-11-26 12:25:43 EST

*** This bug has been marked as a duplicate of 275091 ***

Note You need to log in before you can comment on or make changes to this bug.