Bug 387281 - yum error cElementTree can not update
yum error cElementTree can not update
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-16 12:12 EST by J Hoffman
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-12 11:44:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description J Hoffman 2007-11-16 12:12:04 EST
Description of problem:Upgrading from F7 to f8 yum is broken.

Version-Release number of selected component (if applicable):

How reproducible:every time

Steps to Reproduce:
1.[root@fedora etc]# yum -y upgrade
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   No module named cElementTree

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.5.1 (r251:54863, Oct 30 2007, 13:54:11)
[GCC 4.1.2 20070925 (Red Hat 4.1.2-33)]

If you cannot solve this problem yourself, please go to
the yum faq at:

I have tried all the suggestions I can find and am still receiving this error. 
Also, there does not exist a python-elementtree any longer.

Python import log
[root@fedora etc]# python -d
Python 2.5.1 (r251:54863, Oct 30 2007, 13:54:11)
[GCC 4.1.2 20070925 (Red Hat 4.1.2-33)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import yum
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 38, in <module>
    import comps
  File "/usr/lib/python2.5/site-packages/yum/comps.py", line 21, in <module>
    import cElementTree
ImportError: No module named cElementTree

Actual results:

Expected results:yum to upgrade from f7 to f8

Additional info:
Comment 1 J Hoffman 2007-11-28 14:15:03 EST
I tried installing cElementtree from fc3 which is the last one I could find and
still receive the same error...
Comment 2 Seth Vidal 2007-11-28 15:22:55 EST
could you please run this and let us see the output?

rpm -q yum python rpm fedora-release

Comment 3 J Hoffman 2007-11-29 14:42:38 EST
Here you go..

 rpm -q yum python rpm fedora-release
Comment 4 J Hoffman 2007-11-29 14:45:56 EST
I then removed fedora-release-7-3 and still have the same issue
Comment 5 Seth Vidal 2007-12-06 11:03:21 EST
Do you have another version of python or any python modules anywhere on your
system b/c there's nothing in the above which could be causing this.

also run this:
rpm -qa |grep python

maybe you have some other leftover packages.
Comment 6 J Hoffman 2007-12-19 17:36:56 EST
Fixed it!

Edit all *.py files in the /usr/lib/python2.5/site-packages directory that
contain cElementTree to ElementTree.

Good to go.
Comment 7 Seth Vidal 2007-12-19 18:34:33 EST
there should be no files with cElementTree in them in f8.

Note You need to log in before you can comment on or make changes to this bug.