Bug 387371 - gnome-web-photo doesn't build against xulrunner
gnome-web-photo doesn't build against xulrunner
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 13:36 EST by Bastien Nocera
Modified: 2008-03-31 08:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 05:13:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-11-16 13:36:07 EST
http://koji.fedoraproject.org/koji/getfile?taskID=245093&name=build.log

The portion of configure script is from gecko.m4:
AC_MSG_CHECKING([[whether we have a gtk 2 gecko build]])
AC_RUN_IFELSE(
	[AC_LANG_SOURCE(
		[[#include <mozilla-config.h>
		  #include <string.h>
                  int main(void) {
		    return strcmp (MOZ_DEFAULT_TOOLKIT, "gtk2") != 0;
		  } ]]
	)],
	[result=yes],
	[AC_MSG_ERROR([[This program needs a gtk 2 gecko build]])],
        [result=maybe])
AC_MSG_RESULT([$result])
Comment 1 Erik van Pienbroek 2007-11-18 09:39:42 EST
I think this is a bug which upstream should fix, the file
/usr/include/xulrunner-1.9a9pre/mozilla-config.h contains the following define:

#define MOZ_DEFAULT_TOOLKIT "cairo-gtk2"

So to make the autoconf script compatible with xulrunner, you need to replace
the strcmp function call to something else, like :

return strstr(MOZ_DEFAULT_TOOLKIT, "gtk2") != NULL;
Comment 2 Martin Stransky 2007-11-22 04:57:05 EST
Bastien, this package doesn't compile even against firefox:

checking whether byte ordering is bigendian... no
./configure: line 22257: GNOME_DEBUG_CHECK: command not found
./configure: line 22258: syntax error near unexpected token `maximum'
./configure: line 22258: `GNOME_COMPILE_WARNINGS(maximum)'
error: Bad exit status from /var/tmp/rpm-tmp.62079 (%build)
Comment 3 Bastien Nocera 2007-11-22 05:13:54 EST
(In reply to comment #2)
> Bastien, this package doesn't compile even against firefox:
> 
> checking whether byte ordering is bigendian... no
> ./configure: line 22257: GNOME_DEBUG_CHECK: command not found
> ./configure: line 22258: syntax error near unexpected token `maximum'
> ./configure: line 22258: `GNOME_COMPILE_WARNINGS(maximum)'
> error: Bad exit status from /var/tmp/rpm-tmp.62079 (%build)

Of course. It doesn't compile afterwards because of missing aclocal macros,
which are only available in gnome-common (which we don't ship).

The specific build failure I reported is fixed in GNOME SVN, but it's far from
enough to make gnome-web-photo work. The nsIBadCertListener object doesn't exist
anymore (replaced by the incomplete nsIBadCertListener2), and all the
certificate dialogues in NSSDialog are gone as well.

I guess we can close this bug, as the bug is fixed upstream, but we're not
compiling against xulrunner yet...
Comment 4 Alex Lancaster 2007-12-28 03:03:35 EST
(In reply to comment #3)

> The specific build failure I reported is fixed in GNOME SVN, but it's far from
> enough to make gnome-web-photo work. The nsIBadCertListener object doesn't exist
> anymore (replaced by the incomplete nsIBadCertListener2), and all the
> certificate dialogues in NSSDialog are gone as well.

Link to GNOME bugzilla with upstream bug?

> I guess we can close this bug, as the bug is fixed upstream, but we're not
> compiling against xulrunner yet...

Not sure if I understand, does this mean that once upstream releases a new
version that it *would* compile against xulrunner, and that we haven't done so yet?
Comment 5 Bastien Nocera 2008-03-31 08:53:29 EDT
(In reply to comment #4)
> (In reply to comment #3)
> 
> > The specific build failure I reported is fixed in GNOME SVN, but it's far from
> > enough to make gnome-web-photo work. The nsIBadCertListener object doesn't exist
> > anymore (replaced by the incomplete nsIBadCertListener2), and all the
> > certificate dialogues in NSSDialog are gone as well.
> 
> Link to GNOME bugzilla with upstream bug?

That might have worked if gnome-web-photo had a module in GNOME Bugzilla ;)

> > I guess we can close this bug, as the bug is fixed upstream, but we're not
> > compiling against xulrunner yet...
> 
> Not sure if I understand, does this mean that once upstream releases a new
> version that it *would* compile against xulrunner, and that we haven't done so
yet?

gnome-web-photo compiles against xulrunner in SVN, thanks to Marco.

Note You need to log in before you can comment on or make changes to this bug.