Bug 387821 - ptrace: AltiVec PTRACE_GETVRREGS returns invalid VRSAVE
ptrace: AltiVec PTRACE_GETVRREGS returns invalid VRSAVE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On: 367221
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 17:48 EST by Jan Kratochvil
Modified: 2007-12-04 19:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23.1-49.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 19:10:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel reportedly-fix by Roland McGrath. (1.98 KB, patch)
2007-11-16 17:48 EST, Jan Kratochvil
no flags Details | Diff

  None (edit)
Description Jan Kratochvil 2007-11-16 17:48:28 EST
Description of problem:
PTRACE_GETVRREGS call returns value with an invalid VRSAVE value.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-49.fc8.ppc64

How reproducible:
Always.

Steps to Reproduce:
1. wget -O powerpc-altivec.c
http://sources.redhat.com/cgi-bin/cvsweb.cgi/~checkout~/tests/ptrace-tests/tests/powerpc-altivec.c?cvsroot=systemtap
2. gcc -o powerpc-altivec powerpc-altivec.c -Wall -ggdb2 -m64 -D_GNU_SOURCE
3. ./powerpc-altivec;echo $?
  
Actual results:
[132] 0xa5a5a5a5
1

Expected results:
0

Additional info:
-m64 in command `2.' can be replacted with -m32 with the same results.

While it should be fixed since kernel-2.6.23.1-47.fc8.ppc64 according to the CVS
logs my tests do not confirm it.
Comment 1 Jan Kratochvil 2007-11-16 17:48:28 EST
Created attachment 261921 [details]
kernel reportedly-fix by Roland McGrath.
Comment 3 Roland McGrath 2007-11-19 17:14:18 EST
2.6.23.1-49.fc8 is the one I've tested.
Comment 5 Jan Kratochvil 2007-11-19 17:33:12 EST
Roland, while I believe your patch is right there is some problem that
  mtspr 256,0x01010101
value does not get mapped into `thread.vrsave'.  It should be a problem outside
of utrace.
Comment 6 Roland McGrath 2007-11-19 18:40:25 EST
This flavor of machine simply lacks the Altivec hardware support, though the
ppc64 kernel always supports it when it's there.  I've fixed the test to handle
this.

Note You need to log in before you can comment on or make changes to this bug.